<!doctype html>
<!--
  __  __   ______   ______   __       ______  __  __
/\ \_\ \ /\  ___\ /\  __ \ /\ \     /\__  _\/\ \_\ \
\ \  __ \\ \  __\ \ \  __ \\ \ \____\/_/\ \/\ \  __ \
\ \_\ \_\\ \_____\\ \_\ \_\\ \_____\  \ \_\ \ \_\ \_\
 \/_/\/_/ \/_____/ \/_/\/_/ \/_____/   \/_/  \/_/\/_/

-->
<html lang="en">
  <head>
    <title>Halle Berry Follows a Keto Diet and Intermittent Fasting - Health</title>
    <meta charset="utf-8">
    <link rel="shortcut icon" href="/favicon.ico" type="image/vnd.microsoft.icon">
    <link rel="icon" href="/img/favicons/favicon-32.png" sizes="32x32">
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <link rel="apple-touch-icon" href="/img/favicons/favicon-57.png">
    <link rel="apple-touch-icon" href="/img/favicons/favicon-57.png" sizes="57x57">
    <link rel="apple-touch-icon" href="/img/favicons/favicon-72.png" sizes="72x72">
    <link rel="apple-touch-icon" href="/img/favicons/favicon-76.png" sizes="76x76">
    <link rel="apple-touch-icon" href="/img/favicons/favicon-114.png" sizes="114x114">
    <link rel="apple-touch-icon" href="/img/favicons/favicon-120.png" sizes="120x120">
    <link rel="apple-touch-icon" href="/img/favicons/favicon-144.png" sizes="144x144">
    <link rel="apple-touch-icon" href="/img/favicons/favicon-152.png" sizes="152x152">
    <link rel="apple-touch-icon" href="/img/favicons/favicon-180.png" sizes="180x180">
    <link rel="icon" sizes="192x192" href="/img/favicons/favicon-192.png">
    <link rel="manifest" href="/manifest.json">
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, minimum-scale=1, user-scalable=no">
    <meta name="description" content="Halle Berry recently said she does intermittent fasting on the keto diet. A nutritionist weighs in on if doing both together is healthy.">
    <link rel="canonical" href="https://www.health.com/celebrities/halle-berry-keto-diet-intermittent-fasting">
    <link rel="amphtml" href="https://amp.health.com/celebrities/halle-berry-keto-diet-intermittent-fasting">
      <meta property="og:title" content="Halle Berry Says She Does Intermittent Fasting on the Keto Diet—Is That Healthy?">
    <meta property="og:type" content="article">
    <meta property="og:site_name" content="Health.com">
      <meta property="og:url" content="https://www.health.com/celebrities/halle-berry-keto-diet-intermittent-fasting">
      <meta property="og:description" content="Halle Berry recently said she does intermittent fasting on the keto diet. A nutritionist weighs in on if doing both together is healthy. ">
    <meta name="pinterest:url" content="https://www.health.com/celebrities/halle-berry-keto-diet-intermittent-fasting">
      <meta name="twitter:card" content="summary_large_image">
      <meta name="twitter:url" content="https://www.health.com/celebrities/halle-berry-keto-diet-intermittent-fasting">
      <meta name="twitter:title" content="Halle Berry Says She Does Intermittent Fasting on the Keto Diet—Is That Healthy?">
      <meta name="twitter:description" content="A nutritionist weighs in.">
      <meta name="pinterest:description" content="Halle Berry recently said she does intermittent fasting on the keto diet. A nutritionist weighs in on if doing both together is healthy.">
    <meta name="twitter:site" content="@goodhealth">
    <meta name="pinterest:media" content="https://cdn-img.health.com/sites/default/files/styles/medium_16_9/public/styles/main/public/halle-berry-diet-gettyimages-961643426.jpg?itok&#x3D;IyWd6_Rr">
    <meta name="twitter:image" content="https://cdn-img.health.com/sites/default/files/styles/medium_16_9/public/styles/main/public/halle-berry-diet-gettyimages-961643426.jpg?itok&#x3D;IyWd6_Rr">
    <meta property="og:image" content="https://cdn-img.health.com/sites/default/files/styles/medium_16_9/public/styles/main/public/halle-berry-diet-gettyimages-961643426.jpg?itok&#x3D;IyWd6_Rr">
    <meta property="fb:app_id" content="165082593548215">
    <meta property="fb:pages" content="10053803772">
      <script type="application/ld+json">
        [{"@context":"http://schema.org","@type":"Organization","name":"Health","url":"https://www.health.com","logo":{"@type":"ImageObject","url":"https://www.health.com/img/logo.png"},"sameAs":["https://www.facebook.com/health","https://twitter.com/goodhealth","https://www.pinterest.com/health/","https://www.instagram.com/healthmagazine"]},{"@context":"http://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.health.com","name":"Home","image":null}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.health.com/celebrities","name":"Celebrities","image":null}}]},{"@context":"http://schema.org","@type":"ItemList","itemListElement":[{"@context":"http://schema.org","@type":"SiteNavigationElement","position":1,"name":"Health A-Z","url":"https://www.health.com/diseases-conditions"},{"@context":"http://schema.org","@type":"SiteNavigationElement","position":2,"name":"News","url":"https://www.health.com/news"},{"@context":"http://schema.org","@type":"SiteNavigationElement","position":3,"name":"Fitness","url":"https://www.health.com/fitness"},{"@context":"http://schema.org","@type":"SiteNavigationElement","position":4,"name":"Food","url":"https://www.health.com/food"},{"@context":"http://schema.org","@type":"SiteNavigationElement","position":5,"name":"Weight Loss","url":"https://www.health.com/weight-loss"},{"@context":"http://schema.org","@type":"SiteNavigationElement","position":6,"name":"Life","url":"https://www.health.com/mind-body"},{"@context":"http://schema.org","@type":"SiteNavigationElement","position":7,"name":"Beauty","url":"https://www.health.com/beauty"},{"@context":"http://schema.org","@type":"SiteNavigationElement","position":8,"name":"Newsletter","url":"https://pages.email.health.com/newsletters/?source=HA_CMS_Hamburger"},{"@context":"http://schema.org","@type":"SiteNavigationElement","position":9,"name":"Oral Health","url":"https://www.health.com/condition/oral-health"},{"@context":"http://schema.org","@type":"SiteNavigationElement","position":10,"name":"Health Collections","url":"https://www.health.com/collections"}]},{"@context":"http://schema.org","@type":"Article","headline":"Halle Berry Says She Does Intermittent Fasting on the Keto Diet—Is That Healthy?","image":{"@type":"ImageObject","url":"https://cdn-img.health.com/sites/default/files/styles/large_16_9/public/styles/main/public/halle-berry-diet-gettyimages-961643426.jpg?itok=HcN1mF65&1533585750","width":1984,"height":1116},"video":[{"@type":"VideoObject","name":"7 Celebs on Why They Won’t Diet","description":"These women don't feel the need to diet. Watch the video to find out why.","uploadDate":"1970-01-01T00:00:00.000Z","duration":"PT1M3S","thumbnailUrl":"https://timeincsecure-a.akamaihd.net/rtmp_uds/1125866826/201803/3703/1125866826_5748443351001_5748442514001-vs.jpg?pubId=1125866826&videoId=5748442514001"}],"author":[{"@type":"Person","name":"Samantha Lauriello"}],"publisher":{"@type":"Organization","name":"Health","logo":{"@type":"ImageObject","url":"https://www.health.com/img/logo.png","width":174,"height":60}},"datePublished":"2018-08-06T20:07:34.000Z","dateModified":"2018-08-06T21:51:48.000Z","description":"A nutritionist weighs in.","mainEntityOfPage":"https://www.health.com/celebrities/halle-berry-keto-diet-intermittent-fasting"}]
      </script>
    
    <script id="karma-loader">
    window.useKarma = true; // Temporary flag while toggle between KARMA/TGX is in place.
    window.karma = window.karma || {};
    window.karma.config = {
      apiVersion: 3,
      isMobile: !!window.navigator.userAgent.match(/Mobi/) && !window.navigator.userAgent.match(/iPad/),
      targeting: { 
        ch: "celebrities",   
        sch: "",   
        ctype: "article",   
        mm: "1",   
        tags: [],   
        aid: 528062,   
        cid: 528062,   
        etype: "video",   
        id:'528062',
        // TODO: map legacy Time page types to KARMA page types (less important because KARMA can do the mapping)
        type: 'video_article',
        channel: 'celebrities',
      },
    };
    window.karma.config.callback = window.karma.config.callback || [];
    
    !function(a,e){function r(){if(a.karma.vars=a.karma.vars||{},!(a.karma.vars.kismetReported||null!==e.querySelector('img[src$="kismet/spacer.png"]'))){a.karma.vars.kismetReported=!0;var r=e.createElement("img");r.src="/kismet/spacer.png",e.body.appendChild(r)}}a.karma.cmd=a.karma.cmd||[],a.karma.config.go=function(){a.karma.cmd.push("go")};var t=e.createElement("script");t.src="https://karma.mdpcdn.com/service/js-min/karma.js",t.onload=t.onreadystatechange=function(){var a=this.readyState;a&&"complete"!=a&&"loaded"!=a&&r()},t.onerror=r;var m=e.getElementsByTagName("script")[0];m.parentNode.insertBefore(t,m)}(window,document);
    </script>
    
    
    <script async src="/dist/main.js"></script>
    <script async src="//native.sharethrough.com/assets/sfp.js"></script>
    <script async type="text/javascript">
      WebFontConfig = {
        google: { families: ["Source+Sans+Pro:600,400", "Merriweather:300i,300,700"] }
      };
      (function() {
        let wf = document.createElement('script');
        wf.src = ('https:' == document.location.protocol ? 'https' : 'http') +
            '://ajax.googleapis.com/ajax/libs/webfont/1.6.26/webfont.js';
        wf.type = 'text/javascript';
        wf.async = 'true';
        let s = document.getElementsByTagName('script')[0];
        s.parentNode.insertBefore(wf, s);
      })();
    </script>
    <script type="text/javascript">
      !function(){var analytics=window.analytics=window.analytics||[];if(!analytics.initialize)if(analytics.invoked)window.console&&console.error&&console.error("Segment snippet included twice.");else{analytics.invoked=!0;analytics.methods=["trackSubmit","trackClick","trackLink","trackForm","pageview","identify","reset","group","track","ready","alias","debug","page","once","off","on"];analytics.factory=function(t){return function(){var e=Array.prototype.slice.call(arguments);e.unshift(t);analytics.push(e);return analytics}};for(var t=0;t<analytics.methods.length;t++){var e=analytics.methods[t];analytics[e]=analytics.factory(e)}analytics.load=function(t){var e=document.createElement("script");e.type="text/javascript";e.async=!0;e.src=("https:"===document.location.protocol?"https://":"http://")+"cdn.segment.com/analytics.js/v1/"+t+"/analytics.min.js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(e,n)};analytics.SNIPPET_VERSION="4.0.0";
      analytics.load('XjYNN1mV5ZwafZa6k60GonDxLfJ3BvP1');
      }}();
    </script>
    <script type="text/javascript">
      window.ELEMENT_CLIENT_CONFIG = {
        brand_public_folder: null
      };
    </script>
    <script type="text/javascript">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</script>
    <link rel="dns-prefetch" href="//tia.timeinc.net">
    <link rel="dns-prefetch" href="//imagesvc.timeincapp.com">
    <link rel="dns-prefetch" href="//ape-asset-tag.timeinc.com">
    <link rel="dns-prefetch" href="//cdn.segment.com">
    <link rel="dns-prefetch" href="//subscription-assets.timeinc.com">
      <link rel="stylesheet" type="text/css"
            href="/dist/style.css" lazyload="1">
  </head>
  <body class="template-article " >
    
      <header>
        <nav class="main no-secondary-ribbon no-utility-ribbon contextual-social-enabled has-headline">
    
    
            <section class="container primary">
              <section class="subcontainer">
                <button class="menu" title="Menu" aria-label="Menu">
                  <div class="menu-box">
                    <div class="menu-inner"></div>
                  </div>
                </button>
    
                  <div class="logo">
                        <a class="full-logo mobile-only" href="/" data-action="primary-nav-logo" aria-label="Logo">
                        <?xml version="1.0" encoding="utf-8"?>
                        <!-- Generator: Adobe Illustrator 15.1.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->
                        <!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">
                        <svg xmlns="http://www.w3.org/2000/svg" width="90" height="50" viewBox="0 0 540 150">
                          <g>
                            <polygon points="329.1 146.9 329.1 .2 355.7 .2 355.7 146.9"/>
                            <path d="M436.9,145 C431.7,146.7 422.4,148.3 415.5,148.3 C392.4,148.3 382.7,137.8 382.7,116.5 L382.7,58.5 L364.6,58.5 L364.6,36.6 L382.7,36.6 L382.7,0.1 L409.3,0.1 L409.3,36.6 L436.1,36.6 L436.1,58.5 L409.3,58.5 L409.3,111.1 C409.3,120.3 412.5,124.7 421,124.7 C426.2,124.7 432.7,123.4 436.9,121.7 L436.9,145 Z"/>
                            <polygon points="29.9 58.8 84 58.8 84 .2 113 .2 113 146.9 84 146.9 84 85.8 29.9 85.8 29.9 146.9 .9 146.9 .9 .2 29.9 .2"/>
                            <path d="M219.5 88.4C219.5 59.7 206.9 34 172.4 34 139.9 34 122.7 59 122.7 91.8 122.7 126.8 141.8 149.6 176.4 149.6 190.4 149.6 206.3 147.1 215.7 142.2L215.7 118.3C206.5 123.2 193.1 126.8 180.8 126.8 163.3 126.8 152.4 118.6 150.2 99.8L219.1 99.8C219.5 96 219.5 92.1 219.5 88.4zM150 81C151.9 62.8 160 55.5 172.8 55.5 185 55.5 193.1 65.9 193.1 81L150 81zM272.2 34C257.5 34 245.3 36.4 235.7 40.7L235.7 64.6C245.3 59.8 257.3 57.1 268.8 57.1 286.3 57.1 290.1 66.1 290.2 80.8 283.9 79 276.1 77.9 268.5 77.9 244.1 77.9 226.1 91 226.1 114.5 226.1 135.9 240 149.4 261.8 149.4 274.4 149.4 284 145.3 291.2 136.8L291.2 146.8 317 146.8 317 76.1C317 50.7 303.3 34 272.2 34zM268.2 129.3C258.1 129.3 251.9 124.1 251.9 113.6 251.9 103.6 257.8 96.4 273 96.4 279 96.4 285.1 97.4 290.2 98.8L290.2 104.4C290.2 120 280.2 129.3 268.2 129.3zM503.9 34C491.6 34 480.9 39.2 474.4 46.8L474.4.1 447.7.1 447.7 146.8 474.4 146.8 474.4 86C474.4 68.1 481.3 57.5 495.6 57.5 507.1 57.5 513 65.3 513 80.5L513 146.8 539.7 146.8 539.7 75.3C539.6 52.3 530.7 34 503.9 34z"/>
                          </g>
                        </svg>
                    </a>
                        <a class="full-logo desktop-only" href="/" data-action="primary-nav-logo" aria-label="Logo">
                        <?xml version="1.0" encoding="utf-8"?>
                        <!-- Generator: Adobe Illustrator 15.1.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->
                        <!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">
                        <svg xmlns="http://www.w3.org/2000/svg" width="90" height="50" viewBox="0 0 540 150">
                          <g>
                            <polygon points="329.1 146.9 329.1 .2 355.7 .2 355.7 146.9"/>
                            <path d="M436.9,145 C431.7,146.7 422.4,148.3 415.5,148.3 C392.4,148.3 382.7,137.8 382.7,116.5 L382.7,58.5 L364.6,58.5 L364.6,36.6 L382.7,36.6 L382.7,0.1 L409.3,0.1 L409.3,36.6 L436.1,36.6 L436.1,58.5 L409.3,58.5 L409.3,111.1 C409.3,120.3 412.5,124.7 421,124.7 C426.2,124.7 432.7,123.4 436.9,121.7 L436.9,145 Z"/>
                            <polygon points="29.9 58.8 84 58.8 84 .2 113 .2 113 146.9 84 146.9 84 85.8 29.9 85.8 29.9 146.9 .9 146.9 .9 .2 29.9 .2"/>
                            <path d="M219.5 88.4C219.5 59.7 206.9 34 172.4 34 139.9 34 122.7 59 122.7 91.8 122.7 126.8 141.8 149.6 176.4 149.6 190.4 149.6 206.3 147.1 215.7 142.2L215.7 118.3C206.5 123.2 193.1 126.8 180.8 126.8 163.3 126.8 152.4 118.6 150.2 99.8L219.1 99.8C219.5 96 219.5 92.1 219.5 88.4zM150 81C151.9 62.8 160 55.5 172.8 55.5 185 55.5 193.1 65.9 193.1 81L150 81zM272.2 34C257.5 34 245.3 36.4 235.7 40.7L235.7 64.6C245.3 59.8 257.3 57.1 268.8 57.1 286.3 57.1 290.1 66.1 290.2 80.8 283.9 79 276.1 77.9 268.5 77.9 244.1 77.9 226.1 91 226.1 114.5 226.1 135.9 240 149.4 261.8 149.4 274.4 149.4 284 145.3 291.2 136.8L291.2 146.8 317 146.8 317 76.1C317 50.7 303.3 34 272.2 34zM268.2 129.3C258.1 129.3 251.9 124.1 251.9 113.6 251.9 103.6 257.8 96.4 273 96.4 279 96.4 285.1 97.4 290.2 98.8L290.2 104.4C290.2 120 280.2 129.3 268.2 129.3zM503.9 34C491.6 34 480.9 39.2 474.4 46.8L474.4.1 447.7.1 447.7 146.8 474.4 146.8 474.4 86C474.4 68.1 481.3 57.5 495.6 57.5 507.1 57.5 513 65.3 513 80.5L513 146.8 539.7 146.8 539.7 75.3C539.6 52.3 530.7 34 503.9 34z"/>
                          </g>
                        </svg>
                    </a>
                  </div>
    
                <div class="contextual-social-links mobile-only">
                  <div class="component share  ">
                    <div class="social-container display-flex">
                          <span
                            class="icon icon-facebook-circle-solid social-icon padding-8-right"
                             data-social-service=facebook
                          >
                              <a href="https://www.facebook.com/sharer/sharer.php?u&#x3D;https://www.health.com/celebrities/halle-berry-keto-diet-intermittent-fasting?utm_source&#x3D;facebook.com%26utm_medium&#x3D;social%26utm_campaign&#x3D;social-button-sharing" class="display-block component popup" target="_blank" title="facebook share" aria-label="facebook share">
                            <svg xmlns="http://www.w3.org/2000/svg" width="32" height="32" viewBox="200 0 400 400"><path fill="#3B5999" d="M400 400c-110 0-200-90-200-200S290 0 400 0s200 90 200 200-90 200-200 200z"/><path fill="#FFF" d="M422.5 160h15v-21.2c-2.5 0-5 0-7.5-1.2h-13.8c-7.5 0-13.8 1.2-18.8 5-6.2 5-10 11.2-11.2 18.8 0 2.5-1.2 6.2-1.2 8.8v17.5h-22.5v23.8H385v61.2h26.2v-61.2h22.5c1.2-7.5 2.5-16.2 3.7-25h-25V169c-1.2-6.5 3.8-9 10.1-9"/></svg>    </a>
                          </span>
                                  <span
                              class="icon icon-pinterest-circle-solid social-icon padding-8-right"
                               data-social-service=pinterest
                            >
                                <a href="https://www.pinterest.com/pin/create/link/?url&#x3D;https%3A%2F%2Fwww.health.com%2Fcelebrities%2Fhalle-berry-keto-diet-intermittent-fasting&amp;media&#x3D;https%3A%2F%2Fcdn-img.health.com%2Fsites%2Fdefault%2Ffiles%2Fstyles%2Flarge_16_9%2Fpublic%2Fstyles%2Fmain%2Fpublic%2Fhalle-berry-diet-gettyimages-961643426.jpg%3Fitok%3DHcN1mF65%261533585750&amp;description&#x3D;Halle%20Berry%20Says%20She%20Does%20Intermittent%20Fasting%20on%20the%20Keto%20Diet%E2%80%94Is%20That%20Healthy%3F%20%7C%20Halle%20Berry%20recently%20said%20she%20does%20intermittent%20fasting%20on%20the%20keto%20diet.%20A%20nutritionist%20weighs%20in%20on%20if%20doing%20both%20together%20is%20healthy.&amp;utm_source&#x3D;pinterest.com&amp;utm_medium&#x3D;social&amp;utm_campaign&#x3D;health&amp;utm_content&#x3D;20180807&amp;utm_term&#x3D;528062" class="display-block component popup" target="_blank" title="pinterest share" aria-label="pinterest share">
                              <svg xmlns="http://www.w3.org/2000/svg" width="32" height="32" viewBox="0 0 32 32"><path fill="#BD071D" d="M16 32C7.2 32 0 24.8 0 16S7.2 0 16 0s16 7.2 16 16-7.2 16-16 16z"/><path fill="#FFF" d="M15 18.1s0 .1 0 0c-.5 1.9-.5 2.3-1 3.1-.2.4-.5.8-.8 1.1l-.1.1c-.1 0-.1-.1-.1-.1-.1-.5-.1-1.1-.1-1.6 0-.7.1-1 1-4.8v-.2c-.2-.6-.3-1.2-.1-1.8.4-1.3 1.9-1.4 2.2-.3.2.7-.3 1.6-.6 2.9-.3 1.1 1 1.8 2.1 1.1 1-.7 1.4-2.5 1.3-3.7-.1-2.4-2.8-3-4.5-2.2-2 .9-2.4 3.3-1.5 4.4.1.1.2.2.2.4-.1.2-.1.4-.2.7 0 .2-.2.2-.3.2-.3-.1-.6-.3-.8-.6-.7-.9-1-2.8 0-4.3 1.1-1.7 3.1-2.4 5-2.2 2.2.3 3.6 1.8 3.9 3.5.1.8 0 2.7-1.1 4.1-1.3 1.6-3.3 1.7-4.3.7-.1-.3-.1-.4-.2-.5"/></svg>    </a>
                            </span>
                          <span
                            class="icon icon-twitter-circle-solid social-icon padding-8-right"
                             data-social-service=twitter
                          >
                              <a href="https://twitter.com/intent/tweet?text&#x3D;Halle%20Berry%20Says%20She%20Does%20Intermittent%20Fasting%20on%20the%20Keto%20Diet%E2%80%94Is%20That%20Healthy%3F%20https://www.health.com/celebrities/halle-berry-keto-diet-intermittent-fasting?utm_source&#x3D;twitter.com%26utm_medium&#x3D;social%26utm_campaign&#x3D;social-button-sharing%20via%20@goodhealth" class="display-block component popup" target="_blank" title="twitter share" aria-label="twitter share">
                            <svg xmlns="http://www.w3.org/2000/svg" width="32" height="32" viewBox="0 0 32 32"><path fill="#1DA1F2" d="M16 32C7.2 32 0 24.8 0 16S7.2 0 16 0s16 7.2 16 16-7.2 16-16 16z"/><path fill="#FFF" d="M13.8 19.2c-1.3 0-2.2-1-2.4-1.8.4.1.7.1 1.1 0-.7-.2-1.3-.6-1.7-1.2-.3-.4-.4-.9-.4-1.4.4.2.7.3 1.1.3-.5-.4-.9-.9-1.1-1.6-.1-.7-.1-1.3.3-1.9 1.4 1.7 3.2 2.6 5.3 2.8v-.3c-.1-.6 0-1.2.4-1.7.4-.7 1-1.1 1.7-1.2.9-.1 1.6.1 2.2.7 0 0 .1.1.1 0 .5-.1 1-.3 1.5-.6-.2.6-.6 1.1-1.1 1.4.5-.1 1-.2 1.4-.4-.1.1-.2.3-.3.4-.3.3-.6.7-.9.9v1.3c-.1.8-.3 1.6-.7 2.4-.4.8-.8 1.5-1.4 2.1-1 1-2.2 1.7-3.5 2-.5.1-.9.2-1.4.2-1.5 0-2.9-.3-4.1-1.1h-.1c.9.1 1.7 0 2.6-.4.6-.3 1-.5 1.4-.9"/></svg>    </a>
                          </span>
                                  <span
                              class="icon icon-email-circle-solid social-icon padding-8-right"
                               
                            >
                                <a href="mailto:?subject&#x3D;Halle%20Berry%20Says%20She%20Does%20Intermittent%20Fasting%20on%20the%20Keto%20Diet%E2%80%94Is%20That%20Healthy%3F%20&amp;body&#x3D;https://www.health.com/celebrities/halle-berry-keto-diet-intermittent-fasting?utm_source&#x3D;health.com%26utm_medium&#x3D;email%26utm_campaign&#x3D;social-button-sharing" class="display-block "  title=" share" aria-label=" share">
                              <svg xmlns="http://www.w3.org/2000/svg" width="32" height="32" viewBox="226.8 23.6 400 400"><path fill="#685F55" d="M426.8 423.6c-110.5 0-200-89.5-200-200s89.5-200 200-200 200 89.5 200 200-89.6 200-200 200z"/><path fill="#FFF" d="M339.2 154.9v137.5h175V154.9h-175zm12.6 125V176.8l75 53.1 75-55v105h-150zm6.2-112.5h137.5l-68.8 50-68.7-50z"/></svg>    </a>
                            </span>
                    </div>
                  </div>
                </div>
    
                <div class="title-display desktop-only">
                  <span class="title-text padding-16-right">Halle Berry Says She Does Intermittent Fasting on the Keto Diet—Is That Healthy?</span>
    
                    <span>
                      <div class="component share  ">
                        <div class="social-container display-flex">
                              <span
                                class="icon icon-facebook-circle-solid social-icon padding-8-right"
                                 data-social-service=facebook
                              >
                                  <a href="https://www.facebook.com/sharer/sharer.php?u&#x3D;https://www.health.com/celebrities/halle-berry-keto-diet-intermittent-fasting?utm_source&#x3D;facebook.com%26utm_medium&#x3D;social%26utm_campaign&#x3D;social-button-sharing" class="display-block component popup" target="_blank" title="facebook share" aria-label="facebook share">
                                <svg xmlns="http://www.w3.org/2000/svg" width="32" height="32" viewBox="200 0 400 400"><path fill="#3B5999" d="M400 400c-110 0-200-90-200-200S290 0 400 0s200 90 200 200-90 200-200 200z"/><path fill="#FFF" d="M422.5 160h15v-21.2c-2.5 0-5 0-7.5-1.2h-13.8c-7.5 0-13.8 1.2-18.8 5-6.2 5-10 11.2-11.2 18.8 0 2.5-1.2 6.2-1.2 8.8v17.5h-22.5v23.8H385v61.2h26.2v-61.2h22.5c1.2-7.5 2.5-16.2 3.7-25h-25V169c-1.2-6.5 3.8-9 10.1-9"/></svg>    </a>
                              </span>
                                      <span
                                  class="icon icon-pinterest-circle-solid social-icon padding-8-right"
                                   data-social-service=pinterest
                                >
                                    <a href="https://www.pinterest.com/pin/create/link/?url&#x3D;https%3A%2F%2Fwww.health.com%2Fcelebrities%2Fhalle-berry-keto-diet-intermittent-fasting&amp;media&#x3D;https%3A%2F%2Fcdn-img.health.com%2Fsites%2Fdefault%2Ffiles%2Fstyles%2Flarge_16_9%2Fpublic%2Fstyles%2Fmain%2Fpublic%2Fhalle-berry-diet-gettyimages-961643426.jpg%3Fitok%3DHcN1mF65%261533585750&amp;description&#x3D;Halle%20Berry%20Says%20She%20Does%20Intermittent%20Fasting%20on%20the%20Keto%20Diet%E2%80%94Is%20That%20Healthy%3F%20%7C%20Halle%20Berry%20recently%20said%20she%20does%20intermittent%20fasting%20on%20the%20keto%20diet.%20A%20nutritionist%20weighs%20in%20on%20if%20doing%20both%20together%20is%20healthy.&amp;utm_source&#x3D;pinterest.com&amp;utm_medium&#x3D;social&amp;utm_campaign&#x3D;health&amp;utm_content&#x3D;20180807&amp;utm_term&#x3D;528062" class="display-block component popup" target="_blank" title="pinterest share" aria-label="pinterest share">
                                  <svg xmlns="http://www.w3.org/2000/svg" width="32" height="32" viewBox="0 0 32 32"><path fill="#BD071D" d="M16 32C7.2 32 0 24.8 0 16S7.2 0 16 0s16 7.2 16 16-7.2 16-16 16z"/><path fill="#FFF" d="M15 18.1s0 .1 0 0c-.5 1.9-.5 2.3-1 3.1-.2.4-.5.8-.8 1.1l-.1.1c-.1 0-.1-.1-.1-.1-.1-.5-.1-1.1-.1-1.6 0-.7.1-1 1-4.8v-.2c-.2-.6-.3-1.2-.1-1.8.4-1.3 1.9-1.4 2.2-.3.2.7-.3 1.6-.6 2.9-.3 1.1 1 1.8 2.1 1.1 1-.7 1.4-2.5 1.3-3.7-.1-2.4-2.8-3-4.5-2.2-2 .9-2.4 3.3-1.5 4.4.1.1.2.2.2.4-.1.2-.1.4-.2.7 0 .2-.2.2-.3.2-.3-.1-.6-.3-.8-.6-.7-.9-1-2.8 0-4.3 1.1-1.7 3.1-2.4 5-2.2 2.2.3 3.6 1.8 3.9 3.5.1.8 0 2.7-1.1 4.1-1.3 1.6-3.3 1.7-4.3.7-.1-.3-.1-.4-.2-.5"/></svg>    </a>
                                </span>
                              <span
                                class="icon icon-twitter-circle-solid social-icon padding-8-right"
                                 data-social-service=twitter
                              >
                                  <a href="https://twitter.com/intent/tweet?text&#x3D;Halle%20Berry%20Says%20She%20Does%20Intermittent%20Fasting%20on%20the%20Keto%20Diet%E2%80%94Is%20That%20Healthy%3F%20https://www.health.com/celebrities/halle-berry-keto-diet-intermittent-fasting?utm_source&#x3D;twitter.com%26utm_medium&#x3D;social%26utm_campaign&#x3D;social-button-sharing%20via%20@goodhealth" class="display-block component popup" target="_blank" title="twitter share" aria-label="twitter share">
                                <svg xmlns="http://www.w3.org/2000/svg" width="32" height="32" viewBox="0 0 32 32"><path fill="#1DA1F2" d="M16 32C7.2 32 0 24.8 0 16S7.2 0 16 0s16 7.2 16 16-7.2 16-16 16z"/><path fill="#FFF" d="M13.8 19.2c-1.3 0-2.2-1-2.4-1.8.4.1.7.1 1.1 0-.7-.2-1.3-.6-1.7-1.2-.3-.4-.4-.9-.4-1.4.4.2.7.3 1.1.3-.5-.4-.9-.9-1.1-1.6-.1-.7-.1-1.3.3-1.9 1.4 1.7 3.2 2.6 5.3 2.8v-.3c-.1-.6 0-1.2.4-1.7.4-.7 1-1.1 1.7-1.2.9-.1 1.6.1 2.2.7 0 0 .1.1.1 0 .5-.1 1-.3 1.5-.6-.2.6-.6 1.1-1.1 1.4.5-.1 1-.2 1.4-.4-.1.1-.2.3-.3.4-.3.3-.6.7-.9.9v1.3c-.1.8-.3 1.6-.7 2.4-.4.8-.8 1.5-1.4 2.1-1 1-2.2 1.7-3.5 2-.5.1-.9.2-1.4.2-1.5 0-2.9-.3-4.1-1.1h-.1c.9.1 1.7 0 2.6-.4.6-.3 1-.5 1.4-.9"/></svg>    </a>
                              </span>
                                      <span
                                  class="icon icon-email-circle-solid social-icon padding-8-right"
                                   
                                >
                                    <a href="mailto:?subject&#x3D;Halle%20Berry%20Says%20She%20Does%20Intermittent%20Fasting%20on%20the%20Keto%20Diet%E2%80%94Is%20That%20Healthy%3F%20&amp;body&#x3D;https://www.health.com/celebrities/halle-berry-keto-diet-intermittent-fasting?utm_source&#x3D;health.com%26utm_medium&#x3D;email%26utm_campaign&#x3D;social-button-sharing" class="display-block "  title=" share" aria-label=" share">
                                  <svg xmlns="http://www.w3.org/2000/svg" width="32" height="32" viewBox="226.8 23.6 400 400"><path fill="#685F55" d="M426.8 423.6c-110.5 0-200-89.5-200-200s89.5-200 200-200 200 89.5 200 200-89.6 200-200 200z"/><path fill="#FFF" d="M339.2 154.9v137.5h175V154.9h-175zm12.6 125V176.8l75 53.1 75-55v105h-150zm6.2-112.5h137.5l-68.8 50-68.7-50z"/></svg>    </a>
                                </span>
                        </div>
                      </div>
                    </span>
                </div>
    
                <div class="primary-links mobile-only" data-tracking-zone="nav">
                  <ul class="primary-text-links">
                        <li class="heading-list menu-list-item" data-action="primary-nav-pos-11">
                          <a href="https://www.magazine.store/order/?splitName&#x3D;hth_onsite_w857_mobheader">Subscribe</a>
                        </li>
                  </ul>
                </div>
    
                  <button class="icon search mobile-only js-activate" title="Search" aria-label="Search"><span
      class="icon icon-search utility-icon color-ribbon-primary-text"
       
    >
      <svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path fill="#685F55" d="M14.1 14.751a5.53 5.53 0 1 1 .651-.651L19 18.348l-.652.652-4.248-4.249zm-3.557.4a4.608 4.608 0 1 0 0-9.216 4.608 4.608 0 0 0 0 9.215z"/></svg>
    </span>
    </button>
                  <div class="search-container mobile-only search-open" data-tracking-zone="search">
                    <form action="/search" method="GET">
                        <input name="q" type="text" class="search-field" value="Search" placeholder="Search Health.com" title="Search Health.com">
                    </form>
                  </div>
    
                <div class="primary-links desktop-only" data-tracking-zone="nav">
                  <ul class="primary-text-links">
                        <li class="heading-list menu-list-item has-submenu " data-action="primary-nav-pos-1">
                          <a href="/diseases-conditions" >Health A-Z</a>
                          <aside class="dropdown-menu clearfix">
                            <div class="dropdown-menu-container">
                              <ul class="dropdown-links-list">
                                <li class="heading-list" data-action="primary-menu-health a-z-pos-1"><a href="https://www.health.com/condition/birth-control" >Birth Control</a></li>
                                <li class="heading-list" data-action="primary-menu-health a-z-pos-2"><a href="https://www.health.com/condition/breast-cancer" >Breast Cancer</a></li>
                                <li class="heading-list" data-action="primary-menu-health a-z-pos-3"><a href="https://www.health.com/condition/cold-flu-sinus" >Cold, Flu, and Sinus</a></li>
                                <li class="heading-list" data-action="primary-menu-health a-z-pos-4"><a href="https://www.health.com/condition/crohns-disease" >Crohn&#x27;s Disease</a></li>
                                <li class="heading-list" data-action="primary-menu-health a-z-pos-5"><a href="https://www.health.com/condition/depression" >Depression</a></li>
                                <li class="heading-list" data-action="primary-menu-health a-z-pos-6"><a href="https://www.health.com/condition/type-2-diabetes" >Diabetes (Type 2)</a></li>
                                <li class="heading-list" data-action="primary-menu-health a-z-pos-7"><a href="https://www.health.com/condition/eczema" >Eczema</a></li>
                                <li class="heading-list" data-action="primary-menu-health a-z-pos-8"><a href="https://www.health.com/condition/eye-health" >Eye Health</a></li>
                                <li class="heading-list" data-action="primary-menu-health a-z-pos-9"><a href="https://www.health.com/condition/heart-disease" >Heart Disease</a></li>
                                <li class="heading-list" data-action="primary-menu-health a-z-pos-10"><a href="https://www.health.com/condition/hepatitis-c" >Hepatitis C</a></li>
                                <li class="heading-list" data-action="primary-menu-health a-z-pos-11"><a href="https://www.health.com/condition/hiv" >HIV</a></li>
                                <li class="heading-list" data-action="primary-menu-health a-z-pos-12"><a href="https://www.health.com/condition/multiple-sclerosis" >Multiple Sclerosis</a></li>
                                <li class="heading-list" data-action="primary-menu-health a-z-pos-13"><a href="https://www.health.com/condition/psoriatic-arthritis" >Psoriatic Arthritis</a></li>
                                <li class="heading-list" data-action="primary-menu-health a-z-pos-14"><a href="https://www.health.com/condition/rheumatoid-arthritis" >Rheumatoid Arthritis</a></li>
                                <li class="heading-list" data-action="primary-menu-health a-z-pos-15"><a href="https://www.health.com/condition/skin-conditions" >Skin Conditions</a></li>
                                <li class="heading-list" data-action="primary-menu-health a-z-pos-16"><a href="https://www.health.com/condition/sleep" >Sleep</a></li>
                              </ul>
                            </div>
                          </aside>
                          
                        </li>
                        <li class="heading-list menu-list-item " data-action="primary-nav-pos-2">
                          <a href="/news" >News</a>
                          
                        </li>
                        <li class="heading-list menu-list-item has-submenu " data-action="primary-nav-pos-3">
                          <a href="/fitness" >Fitness</a>
                          <aside class="dropdown-menu clearfix">
                            <div class="dropdown-menu-container">
                              <ul class="dropdown-links-list">
                                <li class="heading-list" data-action="primary-menu-fitness-pos-1"><a href="https://www.health.com/microsites/challenge/core-challenge.html?email-signup&#x3D;true" >30-Day Core Challenge</a></li>
                                <li class="heading-list" data-action="primary-menu-fitness-pos-2"><a href="https://www.health.com/microsites/challenge/total-body-challenge.html?email-signup&#x3D;true" >30-Day Total Body Challenge</a></li>
                              </ul>
                            </div>
                          </aside>
                          
                        </li>
                        <li class="heading-list menu-list-item has-submenu " data-action="primary-nav-pos-4">
                          <a href="/food" >Food</a>
                          <aside class="dropdown-menu clearfix">
                            <div class="dropdown-menu-container">
                              <ul class="dropdown-links-list">
                                <li class="heading-list" data-action="primary-menu-food-pos-1"><a href="/nutrition" >Nutrition</a></li>
                                <li class="heading-list" data-action="primary-menu-food-pos-2"><a href="/recipes" >Recipes</a></li>
                                <li class="heading-list" data-action="primary-menu-food-pos-3"><a href="https://www.health.com/food/giada-de-laurentiis-no-takeout-challenge?package_modal&#x3D;1" >30-Day No Takeout Challenge</a></li>
                                <li class="heading-list" data-action="primary-menu-food-pos-4"><a href="https://www.health.com/microsites/challenge/veggie-challenge.html" >21-Day Veggie Challenge</a></li>
                              </ul>
                            </div>
                          </aside>
                          
                        </li>
                        <li class="heading-list menu-list-item has-submenu " data-action="primary-nav-pos-5">
                          <a href="/weight-loss" >Weight Loss</a>
                          <aside class="dropdown-menu clearfix">
                            <div class="dropdown-menu-container">
                              <ul class="dropdown-links-list">
                                <li class="heading-list" data-action="primary-menu-weight loss-pos-1"><a href="https://www.health.com/microsites/challenge/weight-loss-challenge.html" >30-Day Weight Loss Challenge</a></li>
                              </ul>
                            </div>
                          </aside>
                          
                        </li>
                        <li class="heading-list menu-list-item has-submenu " data-action="primary-nav-pos-6">
                          <a href="/mind-body" >Life</a>
                          <aside class="dropdown-menu clearfix">
                            <div class="dropdown-menu-container">
                              <ul class="dropdown-links-list">
                                <li class="heading-list" data-action="primary-menu-life-pos-1"><a href="/home" >Home</a></li>
                                <li class="heading-list" data-action="primary-menu-life-pos-2"><a href="/mind-body" >Mind &amp; Body</a></li>
                                <li class="heading-list" data-action="primary-menu-life-pos-3"><a href="/family" >Family</a></li>
                                <li class="heading-list" data-action="primary-menu-life-pos-4"><a href="/pets" >Pets</a></li>
                                <li class="heading-list" data-action="primary-menu-life-pos-5"><a href="/sex" >Sex</a></li>
                                <li class="heading-list" data-action="primary-menu-life-pos-6"><a href="/relationships" >Relationships</a></li>
                              </ul>
                            </div>
                          </aside>
                          
                        </li>
                        <li class="heading-list menu-list-item has-submenu " data-action="primary-nav-pos-7">
                          <a href="/beauty" >Beauty</a>
                          <aside class="dropdown-menu clearfix">
                            <div class="dropdown-menu-container">
                              <ul class="dropdown-links-list">
                                <li class="heading-list" data-action="primary-menu-beauty-pos-1"><a href="/style" >Style</a></li>
                                <li class="heading-list" data-action="primary-menu-beauty-pos-2"><a href="/celebrities" >Celebrities</a></li>
                              </ul>
                            </div>
                          </aside>
                          
                        </li>
                        <li class="heading-list menu-list-item " data-action="primary-nav-pos-8">
                          <a href="https://pages.email.health.com/newsletters/?source&#x3D;HA_CMS_Hamburger" >Newsletter</a>
                          
                        </li>
                        <li class="heading-list menu-list-item " data-action="primary-nav-pos-9">
                          <a href="https://www.health.com/condition/oral-health" >Oral Health</a>
                          
                        </li>
                        <li class="heading-list menu-list-item " data-action="primary-nav-pos-10">
                          <a href="https://www.health.com/collections" >Health Collections</a>
                          
                        </li>
                        <li class="heading-list menu-list-item component subscribe-flyout " data-action="primary-nav-pos-11">
                          <a href="https://www.magazine.store/order/?splitName&#x3D;hth_onsite_w857_header">Subscribe</a>
                            <div class="subscribe-cover">
                              <div
                                class="component lazy-image  
                                  
                                  
                                  
                                  "
                                data-src="https://subscription-assets.timeinc.com/current/4478_top1_205_thumb.jpg"
                                data-alt="Subscribe"
                                data-title=""
                                
                                
                                >
                                
                                <noscript>
                                  <div class="inner-container">
                                    <img src="https://subscription-assets.timeinc.com/current/4478_top1_205_thumb.jpg" alt="Subscribe">
                                  </div>
                                </noscript>
                                <div class="inner-container js-inner-container">
                                </div>
                                
                              </div>
                            </div>
                          
                        </li>
                  </ul>
                    <div class="buttons " data-tracking-zone="search">
                      <button class="icon search js-activate" data-action="primary-nav-pos-12" title="Search" aria-label="Search"><span
                      class="icon icon-search utility-icon color-ribbon-primary-text"
                       
                    >
                      <svg xmlns="http://www.w3.org/2000/svg" width="32" height="32" viewBox="0 0 24 24"><path fill="#685F55" d="M14.1 14.751a5.53 5.53 0 1 1 .651-.651L19 18.348l-.652.652-4.248-4.249zm-3.557.4a4.608 4.608 0 1 0 0-9.216 4.608 4.608 0 0 0 0 9.215z"/></svg>
                    </span>
                    </button>
                      <div class="search-container">
                        <form action="/search" name="search" method="GET">
                            <input name="q" type="text" class="search-field" value="" placeholder="Search " title="Search " aria-label="Search ">
                        </form>
                        <button
                          class="icon close close-search"
                          data-action="primary-nav-close-search"><span
                      class="icon icon-close utility-icon color-ribbon-primary-text"
                       
                    >
                      <svg width="14" height="14" viewBox="0 0 14 14" xmlns="http://www.w3.org/2000/svg"><title>Close</title><path fill="#F0F1F3" d="M14 1.41L12.59 0 7 5.59 1.41 0 0 1.41 5.59 7 0 12.59 1.41 14 7 8.41 12.59 14 14 12.59 8.41 7z"/></svg></span>
                    </button>
                      </div>
                    </div>
                    
                    
                    
                </div>
    
    
                
                
                  <div
                      id="div-gpt-cm"
                      data-tier="1"
                            
                    class="ad ad-container ad-wrapper type-4x1 header-text-ad type-cm-subscribe desktop-ad cm-ad karma-ad"
                    data-dimensions="4x1" role="complementary" aria-hidden="true"></div>
                
                
    
              </section>
            </section>
    
    
    
    
        </nav>
          <nav class="main has-promo-tout notification-banner-wrapper" data-embed-type="notification-banner">
          </nav>
    
        <div class="nav-placeholder no-secondary-ribbon no-utility-ribbon"></div>
    
        <nav data-tracking-zone="nav" class="menu no-secondary-ribbon">
          <section class="container">
    
    
              <section class="menu main-menu">
    
                <ul>
                    <li class="menu-item heading-menu has-submenu">
                      <a class="submenu-link"  href="/diseases-conditions">
                        Health A-Z
                      </a>
                        <button class="icon accordion accordion-arrow"><span
                      class="icon icon-down utility-icon"
                       
                    >
                      <svg width="12" height="8" viewBox="0 0 12 8" xmlns="http://www.w3.org/2000/svg"><title>Down</title><path d="M12 2L10.59.59 6 5.17 1.41.59 0 2l6 6z"/></svg>
                    </span>
                    </button>
                        <aside class="submenu">
                          <ul>
                              <li class="menu-item heading-menu">
                                <a   href="https://www.health.com/condition/birth-control">
                                  Birth Control
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="https://www.health.com/condition/breast-cancer">
                                  Breast Cancer
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="https://www.health.com/condition/cold-flu-sinus">
                                  Cold, Flu, and Sinus
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="https://www.health.com/condition/crohns-disease">
                                  Crohn&#x27;s Disease
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="https://www.health.com/condition/depression">
                                  Depression
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="https://www.health.com/condition/type-2-diabetes">
                                  Diabetes (Type 2)
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="https://www.health.com/condition/eczema">
                                  Eczema
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="https://www.health.com/condition/eye-health">
                                  Eye Health
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="https://www.health.com/condition/heart-disease">
                                  Heart Disease
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="https://www.health.com/condition/hepatitis-c">
                                  Hepatitis C
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="https://www.health.com/condition/hiv">
                                  HIV
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="https://www.health.com/condition/multiple-sclerosis">
                                  Multiple Sclerosis
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="https://www.health.com/condition/psoriatic-arthritis">
                                  Psoriatic Arthritis
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="https://www.health.com/condition/rheumatoid-arthritis">
                                  Rheumatoid Arthritis
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="https://www.health.com/condition/skin-conditions">
                                  Skin Conditions
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="https://www.health.com/condition/sleep">
                                  Sleep
                                </a>
                              </li>
                          </ul>
                        </aside>
                    </li>
                    <li class="menu-item heading-menu">
                      <a   href="/news">
                        News
                      </a>
                    </li>
                    <li class="menu-item heading-menu has-submenu">
                      <a class="submenu-link"  href="/fitness">
                        Fitness
                      </a>
                        <button class="icon accordion accordion-arrow"><span
                      class="icon icon-down utility-icon"
                       
                    >
                      <svg width="12" height="8" viewBox="0 0 12 8" xmlns="http://www.w3.org/2000/svg"><title>Down</title><path d="M12 2L10.59.59 6 5.17 1.41.59 0 2l6 6z"/></svg>
                    </span>
                    </button>
                        <aside class="submenu">
                          <ul>
                              <li class="menu-item heading-menu">
                                <a   href="https://www.health.com/microsites/challenge/core-challenge.html?email-signup&#x3D;true">
                                  30-Day Core Challenge
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="https://www.health.com/microsites/challenge/total-body-challenge.html?email-signup&#x3D;true">
                                  30-Day Total Body Challenge
                                </a>
                              </li>
                          </ul>
                        </aside>
                    </li>
                    <li class="menu-item heading-menu has-submenu">
                      <a class="submenu-link"  href="/food">
                        Food
                      </a>
                        <button class="icon accordion accordion-arrow"><span
                      class="icon icon-down utility-icon"
                       
                    >
                      <svg width="12" height="8" viewBox="0 0 12 8" xmlns="http://www.w3.org/2000/svg"><title>Down</title><path d="M12 2L10.59.59 6 5.17 1.41.59 0 2l6 6z"/></svg>
                    </span>
                    </button>
                        <aside class="submenu">
                          <ul>
                              <li class="menu-item heading-menu">
                                <a   href="/nutrition">
                                  Nutrition
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="/recipes">
                                  Recipes
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="https://www.health.com/food/giada-de-laurentiis-no-takeout-challenge?package_modal&#x3D;1">
                                  30-Day No Takeout Challenge
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="https://www.health.com/microsites/challenge/veggie-challenge.html">
                                  21-Day Veggie Challenge
                                </a>
                              </li>
                          </ul>
                        </aside>
                    </li>
                    <li class="menu-item heading-menu has-submenu">
                      <a class="submenu-link"  href="/weight-loss">
                        Weight Loss
                      </a>
                        <button class="icon accordion accordion-arrow"><span
                      class="icon icon-down utility-icon"
                       
                    >
                      <svg width="12" height="8" viewBox="0 0 12 8" xmlns="http://www.w3.org/2000/svg"><title>Down</title><path d="M12 2L10.59.59 6 5.17 1.41.59 0 2l6 6z"/></svg>
                    </span>
                    </button>
                        <aside class="submenu">
                          <ul>
                              <li class="menu-item heading-menu">
                                <a   href="https://www.health.com/microsites/challenge/weight-loss-challenge.html">
                                  30-Day Weight Loss Challenge
                                </a>
                              </li>
                          </ul>
                        </aside>
                    </li>
                    <li class="menu-item heading-menu has-submenu">
                      <a class="submenu-link"  href="/mind-body">
                        Life
                      </a>
                        <button class="icon accordion accordion-arrow"><span
                      class="icon icon-down utility-icon"
                       
                    >
                      <svg width="12" height="8" viewBox="0 0 12 8" xmlns="http://www.w3.org/2000/svg"><title>Down</title><path d="M12 2L10.59.59 6 5.17 1.41.59 0 2l6 6z"/></svg>
                    </span>
                    </button>
                        <aside class="submenu">
                          <ul>
                              <li class="menu-item heading-menu">
                                <a   href="/home">
                                  Home
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="/mind-body">
                                  Mind &amp; Body
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="/family">
                                  Family
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="/pets">
                                  Pets
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="/sex">
                                  Sex
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="/relationships">
                                  Relationships
                                </a>
                              </li>
                          </ul>
                        </aside>
                    </li>
                    <li class="menu-item heading-menu has-submenu">
                      <a class="submenu-link"  href="/beauty">
                        Beauty
                      </a>
                        <button class="icon accordion accordion-arrow"><span
                      class="icon icon-down utility-icon"
                       
                    >
                      <svg width="12" height="8" viewBox="0 0 12 8" xmlns="http://www.w3.org/2000/svg"><title>Down</title><path d="M12 2L10.59.59 6 5.17 1.41.59 0 2l6 6z"/></svg>
                    </span>
                    </button>
                        <aside class="submenu">
                          <ul>
                              <li class="menu-item heading-menu">
                                <a   href="/style">
                                  Style
                                </a>
                              </li>
                              <li class="menu-item heading-menu">
                                <a   href="/celebrities">
                                  Celebrities
                                </a>
                              </li>
                          </ul>
                        </aside>
                    </li>
                    <li class="menu-item heading-menu">
                      <a   href="https://pages.email.health.com/newsletters/?source&#x3D;HA_CMS_Hamburger">
                        Newsletter
                      </a>
                    </li>
                    <li class="menu-item heading-menu">
                      <a   href="https://www.health.com/condition/oral-health">
                        Oral Health
                      </a>
                    </li>
                    <li class="menu-item heading-menu">
                      <a   href="https://www.health.com/collections">
                        Health Collections
                      </a>
                    </li>
                </ul>
              </section>
              <section class="menu second-menu">
    
                <ul>
                    <li class="menu-item heading-menu">
                      <a   href="https://www.magazine.store/health/?utm_source&#x3D;health&amp;utm_medium&#x3D;internal&amp;utm_campaign&#x3D;i805hlr5w857">
                        Subscription
                      </a>
                    </li>
                    <li class="menu-item heading-menu">
                      <a   href="https://www.magazine.store/health/?utm_source&#x3D;health&amp;utm_medium&#x3D;internal&amp;utm_campaign&#x3D;i805hlr5w858">
                        Give a Gift
                      </a>
                    </li>
                    <li class="menu-item heading-menu">
                      <a   href="https://w1.buysub.com/servlet/CSGateway?cds_mag_code&#x3D;HTH">
                        Magazine Customer Service
                      </a>
                    </li>
                    <li class="menu-item heading-menu">
                      <a   href="https://www.health.com/microsites/magazine/fullmediakit.pdf">
                        Advertising
                      </a>
                    </li>
                </ul>
              </section>
    
    
            <section class="menu">
              <label class="heading-tiny">Stay Connected</label>
              <div class="menu-item-styled social-items no-pad-top">
                  <link href="https://www.facebook.com/health">
                  <span
                    class="icon icon-facebook-circle-stroke social-stroke-icon color-accent margin-4-right"
                     
                  >
                      <a href="https://www.facebook.com/health" class="display-block " target="_blank" title=" share" aria-label=" share">
                    <svg width="36" height="36" xmlns="http://www.w3.org/2000/svg"><g fill-rule="evenodd" fill="none" stroke="null"><path d="M32.95 18c0 8.258-6.693 14.95-14.95 14.95S3.05 26.26 3.05 18 9.742 3.05 18 3.05 32.95 9.74 32.95 18" stroke-width="2" stroke="#B7B4B4"/><path d="M19.718 13.698c.433-.014.866-.004 1.3-.004h.18V11.57c-.232-.023-.473-.054-.716-.065-.445-.02-.89-.04-1.336-.03-.68.013-1.323.17-1.884.55-.644.435-.998 1.05-1.132 1.773-.057.3-.07.607-.08.912-.01.477-.002.953 0 1.43v.18h-2.16v2.373h2.147v5.966h2.622V18.7h2.134l.33-2.385h-.482c-.608.002-2.004 0-2.004 0s.006-1.177.02-1.687c.02-.7.46-.912 1.057-.932" fill="#B7B4B4"/></g></svg>    </a>
                  </span>
                  <link href="https://twitter.com/goodhealth">
                  <span
                    class="icon icon-twitter-circle-stroke social-stroke-icon color-accent margin-4-right"
                     
                  >
                      <a href="https://twitter.com/goodhealth" class="display-block " target="_blank" title=" share" aria-label=" share">
                    <svg width="36" height="36" xmlns="http://www.w3.org/2000/svg"><g fill-rule="evenodd" fill="none" stroke="null"><path d="M32.977 18c0 8.272-6.705 14.976-14.977 14.976S3.023 26.272 3.023 18C3.023 9.728 9.728 3.024 18 3.024S32.977 9.728 32.977 18" stroke-width="2" stroke="#B7B4B4"/><path d="M15.783 21.476c-1.48-.052-2.404-1.114-2.65-1.976.413.078.82.063 1.222-.037.01-.002.02-.01.04-.018-.8-.187-1.42-.616-1.848-1.307-.286-.46-.422-.962-.418-1.514.4.214.81.333 1.26.345-.607-.44-1.01-1.01-1.177-1.73-.164-.73-.057-1.42.306-2.07 1.54 1.813 3.492 2.81 5.872 2.973-.02-.113-.037-.21-.048-.31-.08-.67.054-1.295.416-1.86.454-.71 1.1-1.15 1.93-1.29.96-.156 1.796.117 2.495.795.046.045.085.06.15.045.586-.125 1.14-.335 1.657-.635l.04-.02h.02c-.225.664-.635 1.174-1.22 1.55.553-.06 1.08-.206 1.586-.426l.01.013c-.11.143-.215.29-.327.427-.302.373-.65.7-1.035.984-.034.025-.05.05-.05.09.016.424 0 .846-.053 1.266-.11.885-.352 1.73-.73 2.534-.39.833-.9 1.585-1.54 2.246-1.083 1.12-2.39 1.844-3.912 2.18-.52.115-1.05.173-1.585.19-1.64.046-3.16-.36-4.554-1.224l-.066-.043c.996.107 1.94-.02 2.85-.393.484-.197.93-.457 1.354-.79" fill="#B7B4B4"/></g></svg>    </a>
                  </span>
                  <link href="https://www.pinterest.com/health/">
                  <span
                    class="icon icon-pinterest-circle-stroke social-stroke-icon color-accent margin-4-right"
                     
                  >
                      <a href="https://www.pinterest.com/health/" class="display-block " target="_blank" title=" share" aria-label=" share">
                    <svg width="36" height="36" xmlns="http://www.w3.org/2000/svg"><g fill-rule="evenodd" fill="none" stroke="null"><path d="M32.976 18c0 8.272-6.705 14.976-14.976 14.976-8.27 0-14.976-6.704-14.976-14.976C3.024 9.728 9.73 3.024 18 3.024S32.976 9.728 32.976 18" stroke-width="2" stroke="#B7B4B4"/><path d="M17.162 20.54c-.012.038-.022.072-.03.105-.505 1.976-.562 2.415-1.08 3.332-.247.437-.525.85-.834 1.246-.034.044-.067.102-.137.088-.07-.01-.08-.08-.08-.14-.08-.6-.13-1.2-.11-1.81.03-.79.13-1.06 1.15-5.34.02-.06 0-.12-.02-.18-.24-.65-.29-1.32-.08-2 .46-1.46 2.12-1.57 2.41-.36.18.75-.292 1.72-.654 3.16-.3 1.19 1.1 2.04 2.298 1.17 1.106-.8 1.534-2.72 1.45-4.08-.16-2.71-3.13-3.29-5.02-2.42-2.16 1-2.65 3.68-1.675 4.91.126.157.22.25.18.41-.06.244-.117.49-.186.735-.05.184-.2.25-.384.175-.36-.148-.66-.377-.9-.678-.83-1.026-1.07-3.057.03-4.776 1.212-1.906 3.47-2.676 5.534-2.443 2.468.28 4.02 1.964 4.316 3.873.13.87.035 3.012-1.186 4.53-1.404 1.74-3.68 1.854-4.73.785-.08-.08-.146-.18-.225-.272" fill="#B7B4B4"/></g></svg>    </a>
                  </span>
                  <link href="https://www.instagram.com/healthmagazine">
                  <span
                    class="icon icon-instagram-circle-stroke social-stroke-icon color-accent margin-4-right"
                     
                  >
                      <a href="https://www.instagram.com/healthmagazine" class="display-block " target="_blank" title=" share" aria-label=" share">
                    <svg width="36" height="36" xmlns="http://www.w3.org/2000/svg"><g fill-rule="evenodd" fill="none" stroke="null"><path d="M32.95 18c0 8.257-6.693 14.95-14.95 14.95S3.05 26.258 3.05 18 9.742 3.05 18 3.05 32.95 9.742 32.95 18" stroke-width="2" stroke="#B7B4B4"/><path d="M22.624 22c0 .344-.28.624-.623.624h-8.47c-.342 0-.62-.28-.62-.623v-5.13h1.218c-.07.29-.104.59-.104.9 0 2.07 1.677 3.75 3.75 3.75 2.07 0 3.75-1.68 3.75-3.75 0-.306-.038-.604-.108-.89h1.22V22zm-7.137-5.13c.356-.907 1.24-1.552 2.274-1.552 1.04 0 1.92.645 2.28 1.553.11.28.17.58.17.9 0 1.347-1.1 2.444-2.44 2.444-1.345 0-2.442-1.097-2.442-2.443 0-.314.06-.615.17-.89zm4.916-3.576c0-.19.154-.344.344-.344h1.49c.19 0 .344.154.344.344v1.49c0 .19-.15.344-.34.344h-1.49c-.19 0-.34-.154-.34-.344v-1.49zM22 11.592h-8.478c-1.065 0-1.93.865-1.93 1.93v8.48c0 1.064.865 1.93 1.93 1.93h8.48c1.065 0 1.93-.866 1.93-1.93v-8.48c0-1.065-.865-1.93-1.93-1.93z" fill="#B7B4B4"/></g></svg>    </a>
                  </span>
              </div>
            </section>
          </section>
        </nav>
    
        <div class="sidebar-overlay-menu desktop-only hidden"></div>
    
        <div class="menu-overlay"></div>
    
          <div class="under-nav" data-tracking-zone="under-nav">
          
                <div class="component feed clearfix header-recirc"
                  data-endpoint="/element-api/content-proxy/documents"data-request-data="%7B%22count%22%3A4%2C%22crops%22%3A%22thumbnail%2Cmarquee_large_2x%2Capp_list_thumbnail_2x%2Cmedium_2x%22%2C%22types%22%3A%22article%2Cgallery%2Crecipe%22%2C%22excluded%22%3A528062%2C%22vocabulary%22%3A%22category%22%2C%22term%22%3A%22Celebrities%22%2C%22term_id%22%3A%22123%22%7D"data-partial="list-item"data-variation="header-recirc"data-flair-size="24"data-type="feed"data-native_ad="%7B%22dimensions%22%3A%22480x100%22%2C%22placement%22%3A%22nav%22%2C%22priority%22%3A6%7D"data-nativekey="FaD9hFvGDf28VDTYabMon8Mo">
                  
                
                </div>
          </div>
    
          	<div class="component adhesion-ad mobile-ad">
          	 	<div class="adhesion-ad-container">
          	    	
          	    	
          	    	  <div
          	    	      id="div-gpt-mob-adhesive-banner-fixed"
          	    	      data-tier="1"
          	    	            
          	    	    class="ad ad-container ad-wrapper type-320-flex mobile-ad karma-ad"
          	    	    data-dimensions="102x1;300x50;320x50" role="complementary" aria-hidden="true"></div>
          	    	
          	    	
          	  </div>
          	</div>
    
          <div class="ad-wrapper outer tablet-ad desktop-ad full-column">
              
                <div
                  class="ad-sticky-container desktop-ad tablet-ad karma-ad"
                >
              
                <div
                    id="div-gpt-leaderboard-flex-1"
                    data-tier="1"
                          
                  class="ad ad-container ad-wrapper type-banner type-970x90-flex margin-16-tb desktop-ad tablet-ad karma-ad"
                  data-dimensions="101x1;970x90;970x66;970x250;728x90" role="complementary" aria-hidden="true"></div>
                </div>
              
              
          </div>
    
    
      </header>
    <div class="container-full-width with-sidebar-right">
  <div class="inner-container">
    <main class="content article clearfix">
      <meta content="https://www.health.com/celebrities/halle-berry-keto-diet-intermittent-fasting">
      <div class="article-header text-align-center padding-24-bottom">
        <!-- Headline -->
        <div class="intro article-info">
          
          <div class="intro-top margin-8-bottom clearfix">
              <!-- Breadcrumbs -->
                <div class="partial breadcrumbs clearfix " >
                  <nav role="navigation">
                    <ol>
                          <li>
                            <a href="/">
                              <span>Home</span>
                            </a>
                          </li>
                          <li>
                            <a href="/celebrities">
                              <span>Celebrities</span>
                            </a>
                          </li>
                    </ol>
                  </nav>
                </div>
          </div>
          <h1 class="headline heading-content margin-8-top margin-16-bottom">Halle Berry Says She Does Intermittent Fasting on the Keto Diet—Is That Healthy?</h1>
            <div id="karma-lazy-sponsorLogo" class="margin-16-bottom"></div>
        </div>
        <!-- Share -->
        <div class="share center-pseudo">
          <div class="cf clear-fix clearfix" data-tracking-zone="top-menu">
            <div class="component share  ">
              <div class="social-container display-flex">
                    <span
                      class="icon icon-facebook-circle-solid social-icon padding-8-right"
                       data-social-service=facebook
                    >
                        <a href="https://www.facebook.com/sharer/sharer.php?u&#x3D;https://www.health.com/celebrities/halle-berry-keto-diet-intermittent-fasting?utm_source&#x3D;facebook.com%26utm_medium&#x3D;social%26utm_campaign&#x3D;social-button-sharing" class="display-block component popup" target="_blank" title="facebook share" aria-label="facebook share">
                      <svg xmlns="http://www.w3.org/2000/svg" width="32" height="32" viewBox="200 0 400 400"><path fill="#3B5999" d="M400 400c-110 0-200-90-200-200S290 0 400 0s200 90 200 200-90 200-200 200z"/><path fill="#FFF" d="M422.5 160h15v-21.2c-2.5 0-5 0-7.5-1.2h-13.8c-7.5 0-13.8 1.2-18.8 5-6.2 5-10 11.2-11.2 18.8 0 2.5-1.2 6.2-1.2 8.8v17.5h-22.5v23.8H385v61.2h26.2v-61.2h22.5c1.2-7.5 2.5-16.2 3.7-25h-25V169c-1.2-6.5 3.8-9 10.1-9"/></svg>    </a>
                    </span>
                            <span
                        class="icon icon-pinterest-circle-solid social-icon padding-8-right"
                         data-social-service=pinterest
                      >
                          <a href="https://www.pinterest.com/pin/create/link/?url&#x3D;https%3A%2F%2Fwww.health.com%2Fcelebrities%2Fhalle-berry-keto-diet-intermittent-fasting&amp;media&#x3D;https%3A%2F%2Fcdn-img.health.com%2Fsites%2Fdefault%2Ffiles%2Fstyles%2Flarge_16_9%2Fpublic%2Fstyles%2Fmain%2Fpublic%2Fhalle-berry-diet-gettyimages-961643426.jpg%3Fitok%3DHcN1mF65%261533585750&amp;description&#x3D;Halle%20Berry%20Says%20She%20Does%20Intermittent%20Fasting%20on%20the%20Keto%20Diet%E2%80%94Is%20That%20Healthy%3F%20%7C%20Halle%20Berry%20recently%20said%20she%20does%20intermittent%20fasting%20on%20the%20keto%20diet.%20A%20nutritionist%20weighs%20in%20on%20if%20doing%20both%20together%20is%20healthy.&amp;utm_source&#x3D;pinterest.com&amp;utm_medium&#x3D;social&amp;utm_campaign&#x3D;health&amp;utm_content&#x3D;20180807&amp;utm_term&#x3D;528062" class="display-block component popup" target="_blank" title="pinterest share" aria-label="pinterest share">
                        <svg xmlns="http://www.w3.org/2000/svg" width="32" height="32" viewBox="0 0 32 32"><path fill="#BD071D" d="M16 32C7.2 32 0 24.8 0 16S7.2 0 16 0s16 7.2 16 16-7.2 16-16 16z"/><path fill="#FFF" d="M15 18.1s0 .1 0 0c-.5 1.9-.5 2.3-1 3.1-.2.4-.5.8-.8 1.1l-.1.1c-.1 0-.1-.1-.1-.1-.1-.5-.1-1.1-.1-1.6 0-.7.1-1 1-4.8v-.2c-.2-.6-.3-1.2-.1-1.8.4-1.3 1.9-1.4 2.2-.3.2.7-.3 1.6-.6 2.9-.3 1.1 1 1.8 2.1 1.1 1-.7 1.4-2.5 1.3-3.7-.1-2.4-2.8-3-4.5-2.2-2 .9-2.4 3.3-1.5 4.4.1.1.2.2.2.4-.1.2-.1.4-.2.7 0 .2-.2.2-.3.2-.3-.1-.6-.3-.8-.6-.7-.9-1-2.8 0-4.3 1.1-1.7 3.1-2.4 5-2.2 2.2.3 3.6 1.8 3.9 3.5.1.8 0 2.7-1.1 4.1-1.3 1.6-3.3 1.7-4.3.7-.1-.3-.1-.4-.2-.5"/></svg>    </a>
                      </span>
                    <span
                      class="icon icon-twitter-circle-solid social-icon padding-8-right"
                       data-social-service=twitter
                    >
                        <a href="https://twitter.com/intent/tweet?text&#x3D;Halle%20Berry%20Says%20She%20Does%20Intermittent%20Fasting%20on%20the%20Keto%20Diet%E2%80%94Is%20That%20Healthy%3F%20https://www.health.com/celebrities/halle-berry-keto-diet-intermittent-fasting?utm_source&#x3D;twitter.com%26utm_medium&#x3D;social%26utm_campaign&#x3D;social-button-sharing%20via%20@goodhealth" class="display-block component popup" target="_blank" title="twitter share" aria-label="twitter share">
                      <svg xmlns="http://www.w3.org/2000/svg" width="32" height="32" viewBox="0 0 32 32"><path fill="#1DA1F2" d="M16 32C7.2 32 0 24.8 0 16S7.2 0 16 0s16 7.2 16 16-7.2 16-16 16z"/><path fill="#FFF" d="M13.8 19.2c-1.3 0-2.2-1-2.4-1.8.4.1.7.1 1.1 0-.7-.2-1.3-.6-1.7-1.2-.3-.4-.4-.9-.4-1.4.4.2.7.3 1.1.3-.5-.4-.9-.9-1.1-1.6-.1-.7-.1-1.3.3-1.9 1.4 1.7 3.2 2.6 5.3 2.8v-.3c-.1-.6 0-1.2.4-1.7.4-.7 1-1.1 1.7-1.2.9-.1 1.6.1 2.2.7 0 0 .1.1.1 0 .5-.1 1-.3 1.5-.6-.2.6-.6 1.1-1.1 1.4.5-.1 1-.2 1.4-.4-.1.1-.2.3-.3.4-.3.3-.6.7-.9.9v1.3c-.1.8-.3 1.6-.7 2.4-.4.8-.8 1.5-1.4 2.1-1 1-2.2 1.7-3.5 2-.5.1-.9.2-1.4.2-1.5 0-2.9-.3-4.1-1.1h-.1c.9.1 1.7 0 2.6-.4.6-.3 1-.5 1.4-.9"/></svg>    </a>
                    </span>
                            <span
                        class="icon icon-email-circle-solid social-icon padding-8-right"
                         
                      >
                          <a href="mailto:?subject&#x3D;Halle%20Berry%20Says%20She%20Does%20Intermittent%20Fasting%20on%20the%20Keto%20Diet%E2%80%94Is%20That%20Healthy%3F%20&amp;body&#x3D;https://www.health.com/celebrities/halle-berry-keto-diet-intermittent-fasting?utm_source&#x3D;health.com%26utm_medium&#x3D;email%26utm_campaign&#x3D;social-button-sharing" class="display-block "  title=" share" aria-label=" share">
                        <svg xmlns="http://www.w3.org/2000/svg" width="32" height="32" viewBox="226.8 23.6 400 400"><path fill="#685F55" d="M426.8 423.6c-110.5 0-200-89.5-200-200s89.5-200 200-200 200 89.5 200 200-89.6 200-200 200z"/><path fill="#FFF" d="M339.2 154.9v137.5h175V154.9h-175zm12.6 125V176.8l75 53.1 75-55v105h-150zm6.2-112.5h137.5l-68.8 50-68.7-50z"/></svg>    </a>
                      </span>
              </div>
            </div>
          </div>
        </div>
      </div>

      <div class="article-content">
          <!-- Lead Media -->
            
            <div class="component video lead-media ">
              <span hidden class="jumpstart-video-data" data-jumpstart-version="v3"></span>
                <div class="jumpstart-video">
                  <video class="video-js" data-embed="default" data-controls="true"
                  data-account="1125866826"
                  data-player="default"
                  data-brand="health"
                  data-video-id="5748442514001"
                  
                  
                  
                    poster="https://cdn-img.health.com/sites/default/files/styles/large_16_9/public/styles/main/public/halle-berry-diet-gettyimages-961643426.jpg?itok&#x3D;HcN1mF65"
                  data-autoplay="true"
                  data-viewplay="true"
                  data-stickyplay="true"
                  
                  data-is-lead="true"></video>
                </div>
            </div>

            <p class="dek margin-16-tb padded-mobile">
              A nutritionist weighs in.
            </p>

          <!-- Author and Date -->
          <div class="author scale-12 padded margin-24-tb clearfix">
            <div class="author-text" data-tracking-zone="author">
           
                         <a class="bold author-name" href="/author/samantha-lauriello">Samantha Lauriello</a>
          
                    <div class="timestamp published-date padding-12-left">
                        August 06, 2018
                    </div>
            </div>
          </div>


          <div class="disclosure padded margin-24-top clearfix">
            <div class="disclosure-inner">Each product we feature has been independently selected and reviewed by our editorial team. If you make a purchase using the links included, we may earn commission.</div>
          </div>

        <!-- Article Content -->
        <div id="article-body" class="article content body clearfix" data-tracking-zone="body">
          <div class="padded">
                <p>If you’re as obsessed with Halle Berry as we are, you probably already know that she swears by the ketogenic diet. The 51-year-old actress has been open about using this high-fat, moderate-protein, low-carb eating plan to manage both her weight and her type 2 diabetes.</p>
                <p>But on the latest installment of her #FitnessFriday Instagram Stories, Berry revealed that in addition to eating keto, she also practices intermittent fasting.</p>
                <div
                  class="component oembed full-width-media padded"
                  data-aspect=""
                >
                  <div class="media-item media-instagram  ">
                    <blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/BebW7m0gHNn/?utm_source=ig_embed" data-instgrm-version="9" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:8px;"> <div style=" background:#F8F8F8; line-height:0; margin-top:40px; padding:62.5% 0; text-align:center; width:100%;"> <div style=" background:url(data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAACwAAAAsCAMAAAApWqozAAAABGdBTUEAALGPC/xhBQAAAAFzUkdCAK7OHOkAAAAMUExURczMzPf399fX1+bm5mzY9AMAAADiSURBVDjLvZXbEsMgCES5/P8/t9FuRVCRmU73JWlzosgSIIZURCjo/ad+EQJJB4Hv8BFt+IDpQoCx1wjOSBFhh2XssxEIYn3ulI/6MNReE07UIWJEv8UEOWDS88LY97kqyTliJKKtuYBbruAyVh5wOHiXmpi5we58Ek028czwyuQdLKPG1Bkb4NnM+VeAnfHqn1k4+GPT6uGQcvu2h2OVuIf/gWUFyy8OWEpdyZSa3aVCqpVoVvzZZ2VTnn2wU8qzVjDDetO90GSy9mVLqtgYSy231MxrY6I2gGqjrTY0L8fxCxfCBbhWrsYYAAAAAElFTkSuQmCC); display:block; height:44px; margin:0 auto -44px; position:relative; top:-22px; width:44px;"></div></div> <p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/BebW7m0gHNn/?utm_source=ig_embed" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">#FitnessFriday Today let’s talk about food. I think the most important part of being healthy and in great shape largely depends on what and when you eat. Being diabetic most of my life, I have always had to take food very seriously. So for years, I have been following the keto or ketogenic diet. I hate the word “diet” so while you’ll see the word diet, just know I encourage you to think of it as a lifestyle change NOT A DIET! Keto is a very low-carb food plan which actually forces your body to burn fat like crazy. I also believe it’s been largely responsible for slowing down my aging process. The keto lifestyle offers so many benefits such as weight loss, (moms that’s how we get rid of our baby bellies), appetite control, more energy and better mental performance.  If you’re like me, you can possibly reverse type 2 diabetes, you’ll experience better physical endurance, better skin and also less acne if that’s an issue. And it even helps control migraines! I’m sharing two links (check Stories!) that will explain the lifestyle in detail and it also offers a plan to help you get started! So today I encourage you to say yes to keto, give it a try... what do you have to lose?! 💪🏽 #FitnessFridayHB</a></p> <p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/halleberry/?utm_source=ig_embed" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Halle Berry</a> (@halleberry) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2018-01-26T21:17:56+00:00">Jan 26, 2018 at 1:17pm PST</time></p></div></blockquote>
                <script async defer src="//www.instagram.com/embed.js"></script>
                  </div>
                </div>
                
                
                  <div
                      id="div-gpt-mob-square-flex-1"
                      data-tier="1"
                      data-lazy-scroll="true"      
                    class="ad ad-container ad-wrapper type-300x250 instream-ad mobile-ad karma-ad"
                    data-dimensions="300x250" role="complementary" aria-hidden="true"></div>
                
                
                
                
                  <div
                      id="div-gpt-leaderboard-fixed-1"
                      data-tier="1"
                      data-lazy-scroll="true"      
                    class="ad ad-container ad-wrapper type-728x90 instream-ad tablet-ad desktop-ad karma-ad"
                    data-dimensions="728x90" role="complementary" aria-hidden="true"></div>
                
                
                <p>“I normally eat two meals a day,” Berry told viewers. “I normally skip breakfast and I sort of fast and I do my green drink or I do my <a href="https://www.health.com/food/what-is-the-bulletproof-diet">bullet coffee</a>,” she added.</p>
                <p>Intermittent fasting is one weight-loss and healthy-eating strategy that doesn’t have a strict rule book. Some people eat only during a specific time window every day, while others restrict their diet for an entire 24 hours a few times each week.</p>
                <p><strong>RELATED: <a href="https://www.health.com/weight-loss/intermittent-fasting-weight-loss">The Healthiest Way to Do Intermittent Fasting, According to a Nutritionist</a></strong></p>
                <p>Fasting in general isn't a smart idea, but intermittent fasting appears to have some upsides. <a href="https://www.health.com/nutrition/intermittent-fasting-diet">Periodic</a><a href="https://www.health.com/nutrition/intermittent-fasting-diet"> fasting</a> has been linked to a lower risk of heart disease, diabetes, and cancer, and it may help slow down aging. It’s also been shown to improve cholesterol levels and stabilize blood sugar, as well as help with weight loss.</p>
                
                
                  <div
                      id="div-sm-inContent-2"
                      data-tier="2"
                      data-lazy-scroll="true"      
                    class="ad ad-container ad-wrapper type-5x5 instream-ad div-sm-inContent  karma-ad"
                    data-dimensions="5x5" role="complementary" aria-hidden="true"></div>
                
                
                <p>Considering those benefits, it’s no surprise Berry is a fan. But is it safe to practice intermittent fasting <i>and</i> the keto diet at the same time?</p>
                <div
                  class="component oembed full-width-media padded"
                  data-aspect=""
                >
                  <div class="media-item media-instagram  ">
                    <blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/BmBeE-mgxXe/?utm_source=ig_embed" data-instgrm-version="9" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:8px;"> <div style=" background:#F8F8F8; line-height:0; margin-top:40px; padding:62.48665955176094% 0; text-align:center; width:100%;"> <div style=" background:url(data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAACwAAAAsCAMAAAApWqozAAAABGdBTUEAALGPC/xhBQAAAAFzUkdCAK7OHOkAAAAMUExURczMzPf399fX1+bm5mzY9AMAAADiSURBVDjLvZXbEsMgCES5/P8/t9FuRVCRmU73JWlzosgSIIZURCjo/ad+EQJJB4Hv8BFt+IDpQoCx1wjOSBFhh2XssxEIYn3ulI/6MNReE07UIWJEv8UEOWDS88LY97kqyTliJKKtuYBbruAyVh5wOHiXmpi5we58Ek028czwyuQdLKPG1Bkb4NnM+VeAnfHqn1k4+GPT6uGQcvu2h2OVuIf/gWUFyy8OWEpdyZSa3aVCqpVoVvzZZ2VTnn2wU8qzVjDDetO90GSy9mVLqtgYSy231MxrY6I2gGqjrTY0L8fxCxfCBbhWrsYYAAAAAElFTkSuQmCC); display:block; height:44px; margin:0 auto -44px; position:relative; top:-22px; width:44px;"></div></div> <p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/BmBeE-mgxXe/?utm_source=ig_embed" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">It’s #FitnessFriday and once again it’s time for #PHITtalks!  Peter and I can’t wait to sit down and answer more of your fitness questions.  Remember, we will do our best to answer as many as we can. Go to my stories and fitness icon later today to see if your question got answered!  Enjoy 💪🏽❤️</a></p> <p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/halleberry/?utm_source=ig_embed" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Halle Berry</a> (@halleberry) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2018-08-03T16:11:17+00:00">Aug 3, 2018 at 9:11am PDT</time></p></div></blockquote>
                <script async defer src="//www.instagram.com/embed.js"></script>
                  </div>
                </div>
                
                
                  <div
                      id="div-gpt-mob-square-flex-3"
                      data-tier="3"
                      data-lazy-scroll="true"      
                    class="ad ad-container ad-wrapper type-300x250 instream-ad mobile-ad karma-ad"
                    data-dimensions="300x250" role="complementary" aria-hidden="true"></div>
                
                
                
                
                  <div
                      id="div-gpt-leaderboard-fixed-3"
                      data-tier="3"
                      data-lazy-scroll="true"      
                    class="ad ad-container ad-wrapper type-728x90 instream-ad tablet-ad desktop-ad karma-ad"
                    data-dimensions="728x90" role="complementary" aria-hidden="true"></div>
                
                
                <p>“Technically there is no reason intermittent fasting and keto can't be combined,” says <em>Health</em> contributing nutrition editor Cynthia Sass, MPH, RD. “Because a keto diet tends to reduce hunger, many people feel it’s easier to stick with intermittent fasting when following a keto plan.” Not much research exists, however, on the effectiveness of pairing the two approaches, Sass adds.<i> </i></p>
                <p><strong>RELATED: <a href="https://www.health.com/weight-loss/ketogenic-diet-vs-atkins-diet">Keto vs. Atkins: Which Is the Better Low-Carb Diet?</a></strong></p>
                <p>If you’re thinking of trying intermittent fasting, you’ll only see results if the food you do eat is healthy. “Simply eating a high-fat diet on a time-restricted schedule can lead to nutrient shortfalls that can negatively impact your health,” says Sass, “even if you're losing weight simultaneously.”</p>
                <p>Sass also emphasizes that intermittent fasting and the keto diet, separate or together, are not right for everyone. “Intermittent fasting and keto are both big commitments that will impact your social life, and for many people are not sustainable long term.”</p>
                
                
                  <div
                      id="div-gpt-mob-square-flex-4"
                      data-tier="4"
                      data-lazy-scroll="true"      
                    class="ad ad-container ad-wrapper type-300x250 instream-ad mobile-ad karma-ad"
                    data-dimensions="300x250" role="complementary" aria-hidden="true"></div>
                
                
                
                
                  <div
                      id="div-gpt-leaderboard-fixed-4"
                      data-tier="4"
                      data-lazy-scroll="true"      
                    class="ad ad-container ad-wrapper type-728x90 instream-ad tablet-ad desktop-ad karma-ad"
                    data-dimensions="728x90" role="complementary" aria-hidden="true"></div>
                
                
                <p>Both eating plans involve significant lifestyle changes that can become overwhelming. “If a method of losing weight feels like a struggle and does not make you feel well both physically and emotionally, it's not right for you, no matter how popular it is,” Sass says.</p>
                <p>Though we can all agree intermittent fasting and the keto diet seem to be working for Berry, it’s important to remember our bodies are uniquely ours and might not have the same needs as someone else’s.</p>
              <div id="karma-lazy-seriesDetails"></div>
          </div>
        </div>
        <!-- Syndication Attribution -->

        <!-- Generic Page Content -->

        <!-- Bottom Recirc -->
          <div class="bottom-recirc padded-mobile "
            data-tracking-zone="bottom-recirc"
          >
              
              <div 
               class="component outbrain clearfix  " data-action="outbrain-component"  data-tracking-zone=outbrain-bottom>
                <div class="OUTBRAIN "
                    data-src="https://www.health.com/celebrities/halle-berry-keto-diet-intermittent-fasting"
                    data-widget-id="AR_24"
                    data-ob-template="health"
                    
                    
                >
                </div>
              </div>
              
                
                
                  <div
                      id="div-gpt-leaderboard-fixed-5"
                      data-tier="3"
                            
                    class="ad ad-container ad-wrapper  desktop-ad tablet-ad karma-ad"
                    data-dimensions="728x90" role="complementary" aria-hidden="true"></div>
                
                
                
                
                  <div
                      id="div-gpt-mob-square-flex-5"
                      data-tier="3"
                            
                    class="ad ad-container ad-wrapper  mobile-ad karma-ad"
                    data-dimensions="300x250" role="complementary" aria-hidden="true"></div>
                
                
                
                    <div class="component feed clearfix bottom-recirc"
                      data-partial="tile"data-variation="bottom-recirc"data-flair-size="30"data-type="feed"data-title="You May Like"data-hide-summary="1"data-native_ad="%7B%22dimensions%22%3A%22482x100%22%2C%22placement%22%3A%22footer%22%2C%22priority%22%3A6%7D"data-nativekey="Y9jDSB2S2tb2CeSHUhQjipNn">
                      <h3 class="subtitle">You May Like</h3>
                    
                                <article
                                  class="partial tile media image-top  has-native-ad type-article"
                                  data-crop="marquee_large_2x"
                                  data-headline-style="heading-content"
                                >
                                    <div class="component native-ad type-482x100 ">
                                      
                                      
                                        <div
                                            id=""
                                            data-tier=""
                                            data-lazy-scroll="true"      
                                          class="ad ad-container ad-wrapper type-nativo type-482x100-flex  karma-ad"
                                          data-dimensions="482x100;1x5" role="complementary" aria-hidden="true"></div>
                                      
                                      
                                    </div>
                                    <!-- Image Media -->
                                    <a class="media-img margin-16-bottom" href="/syndication/jenna-jameson-lost-57-lbs-keto-diet">
                                      <div
                                        class="component lazy-image  marquee_large_2x
                                          
                                          
                                          
                                          "
                                        data-src="https://cdn-img.health.com/sites/default/files/styles/large_16_9/public/1532445120/Screen%20Shot%202018-07-24%20at%2011.11.40%20AM.png?itok&#x3D;hddeXrOy"
                                        data-alt="Jenna Jameson"
                                        data-title="Jenna Jameson"
                                        
                                        
                                        >
                                        
                                        <noscript>
                                          <div class="inner-container">
                                            <img src="https://cdn-img.health.com/sites/default/files/styles/large_16_9/public/1532445120/Screen%20Shot%202018-07-24%20at%2011.11.40%20AM.png?itok&#x3D;hddeXrOy" alt="Jenna Jameson">
                                          </div>
                                        </noscript>
                                        <div class="inner-container js-inner-container">
                                        </div>
                                        
                                      </div>
                                    </a>
                                
                                
                                  <!-- Body -->
                                  <div class="media-body article-info bucket-margin margin-24-bottom clearfix">
                                      <a class="unskinned display-inline-block eyebrow-link margin-4-bottom" href="/weight-loss">
                                        <div class="category heading-eyebrow">
                                          Weight Loss
                                        </div>
                                      </a>
                                
                                    <div class="headline heading-3 heading-content margin-8-bottom media-heading">
                                      <a href="/syndication/jenna-jameson-lost-57-lbs-keto-diet">
                                          Jenna Jameson Lost 57 Lbs. with the Keto Diet After Giving Birth: 'The Cravings Subside'
                                      </a>
                                    </div>
                                
                                    <div class="article-info-extended">
                                
                                
                                      <!-- Summary/Dek -->
                                
                                    </div>
                                
                                
                                  </div>
                                </article>
                                        <article
                                  class="partial tile media image-top  type-gallery"
                                  data-crop="marquee_large_2x"
                                  data-headline-style="heading-content"
                                >
                                    <!-- Image Media -->
                                    <a class="media-img margin-16-bottom" href="/food/keto-diet-recipes-instant-pot">
                                      <div
                                        class="component lazy-image  marquee_large_2x
                                          
                                          
                                          
                                          "
                                        data-src="https://cdn-img.health.com/sites/default/files/styles/medium_16_9/public/styles/main/public/instant-pot_0_0.jpg?itok&#x3D;MK5a4LWD"
                                        data-alt="instant-pot-keto-diet-recipes-ideas"
                                        data-title="Trying the keto diet? Your Instant Pot can help"
                                        
                                        
                                        >
                                        
                                        <noscript>
                                          <div class="inner-container">
                                            <img src="https://cdn-img.health.com/sites/default/files/styles/medium_16_9/public/styles/main/public/instant-pot_0_0.jpg?itok&#x3D;MK5a4LWD" alt="instant-pot-keto-diet-recipes-ideas">
                                          </div>
                                        </noscript>
                                        <div class="inner-container js-inner-container">
                                        </div>
                                        
                                            <div class="image-flair">
                                               <span class="icon utility-icon icon-camera-square-solid color-accent">
                                                <span class="flair"><svg xmlns=http://www.w3.org/2000/svg xmlns:svg=http://www.w3.org/2000/svg xmlns:xlink=http://www.w3.org/1999/xlink width="30" height="30" viewBox="0 0 30 30">
                                        <defs>
                                          <polygon id=recirc-gallery-solid-a points="30 30.001 0 30.001 0 .001 30 .001 30 30.001"/>
                                        </defs>
                                        <g>
                                          <g fill=none fill-rule=evenodd id=svg_1>
                                            <use fill=#B7B4B4 id=svg_3 xlink:href=#recirc-gallery-solid-a />
                                            <polygon id=svg_4 points="21.586 20.089 8.348 20.089 8.348 11.511 12.028 11.511 12.028 9.363 17.905 9.363 17.905 11.511 21.586 11.511"fill=#FFF style=fill:#fff!important /><path d="m14.96665,12.93857c-1.21765,0 -2.2103,0.93943 -2.2103,2.13429c0,1.19657 0.99265,2.148 2.2103,2.148c1.21764,0 2.21029,-0.93857 2.21029,-2.13429c0,-1.19657 -0.99265,-2.148 -2.21029,-2.148"fill=#B7B4B4 id=svg_5 />
                                          </g>
                                        </g>
                                      </svg>
                                      </span>
                                              </span>
                                            </div>
                                          </div>
                                    </a>
                                
                                
                                  <!-- Body -->
                                  <div class="media-body article-info bucket-margin margin-24-bottom clearfix">
                                      <a class="unskinned display-inline-block eyebrow-link margin-4-bottom" href="/food">
                                        <div class="category heading-eyebrow">
                                          Food
                                        </div>
                                      </a>
                                
                                    <div class="headline heading-3 heading-content margin-8-bottom media-heading">
                                      <a href="/food/keto-diet-recipes-instant-pot">
                                          6 Keto-Friendly Recipes for Your Instant Pot
                                      </a>
                                    </div>
                                
                                    <div class="article-info-extended">
                                
                                
                                      <!-- Summary/Dek -->
                                
                                    </div>
                                
                                
                                  </div>
                                </article>
                                        <article
                                  class="partial tile media image-top  type-article"
                                  data-crop="marquee_large_2x"
                                  data-headline-style="heading-content"
                                >
                                    <!-- Image Media -->
                                    <a class="media-img margin-16-bottom" href="/weight-loss/woman-lost-40-pounds-in-8-months-on-keto-diet">
                                      <div
                                        class="component lazy-image  marquee_large_2x
                                          
                                          
                                          
                                          "
                                        data-src="https://cdn-img.health.com/sites/default/files/styles/large_16_9/public/1528309433/slack-imgs-2.jpg?itok&#x3D;vaCtEngi"
                                        data-alt="Sharon Sandhu"
                                        data-title="Sharon Sandhu"
                                        
                                        
                                        >
                                        
                                        <noscript>
                                          <div class="inner-container">
                                            <img src="https://cdn-img.health.com/sites/default/files/styles/large_16_9/public/1528309433/slack-imgs-2.jpg?itok&#x3D;vaCtEngi" alt="Sharon Sandhu">
                                          </div>
                                        </noscript>
                                        <div class="inner-container js-inner-container">
                                        </div>
                                        
                                      </div>
                                    </a>
                                
                                
                                  <!-- Body -->
                                  <div class="media-body article-info bucket-margin margin-24-bottom clearfix">
                                      <a class="unskinned display-inline-block eyebrow-link margin-4-bottom" href="/weight-loss">
                                        <div class="category heading-eyebrow">
                                          Weight Loss
                                        </div>
                                      </a>
                                
                                    <div class="headline heading-3 heading-content margin-8-bottom media-heading">
                                      <a href="/weight-loss/woman-lost-40-pounds-in-8-months-on-keto-diet">
                                          This Woman Has Lost 40 Pounds in 8 Months Since Starting the Keto Diet
                                      </a>
                                    </div>
                                
                                    <div class="article-info-extended">
                                
                                
                                      <!-- Summary/Dek -->
                                
                                    </div>
                                
                                
                                  </div>
                                </article>
                                        <article
                                  class="partial tile media image-top  type-article"
                                  data-crop="marquee_large_2x"
                                  data-headline-style="heading-content"
                                >
                                    <!-- Image Media -->
                                    <a class="media-img margin-16-bottom" href="/food/summer-barbecue-keto-recipes-on-pinterest">
                                      <div
                                        class="component lazy-image  marquee_large_2x
                                          
                                          
                                          
                                          "
                                        data-src="https://cdn-img.health.com/sites/default/files/styles/large_16_9/public/styles/main/public/keto-lemon-bars-2.png?itok&#x3D;Z7gB82of"
                                        data-alt="Keto Lemon Bars"
                                        data-title="Keto Lemon Bars"
                                        
                                        
                                        >
                                        
                                        <noscript>
                                          <div class="inner-container">
                                            <img src="https://cdn-img.health.com/sites/default/files/styles/large_16_9/public/styles/main/public/keto-lemon-bars-2.png?itok&#x3D;Z7gB82of" alt="Keto Lemon Bars">
                                          </div>
                                        </noscript>
                                        <div class="inner-container js-inner-container">
                                        </div>
                                        
                                      </div>
                                    </a>
                                
                                
                                  <!-- Body -->
                                  <div class="media-body article-info bucket-margin margin-24-bottom clearfix">
                                      <a class="unskinned display-inline-block eyebrow-link margin-4-bottom" href="/food">
                                        <div class="category heading-eyebrow">
                                          Food
                                        </div>
                                      </a>
                                
                                    <div class="headline heading-3 heading-content margin-8-bottom media-heading">
                                      <a href="/food/summer-barbecue-keto-recipes-on-pinterest">
                                          15 Keto Recipes for a Summer Barbecue That Are All Over Pinterest
                                      </a>
                                    </div>
                                
                                    <div class="article-info-extended">
                                
                                
                                      <!-- Summary/Dek -->
                                
                                    </div>
                                
                                
                                  </div>
                                </article>
                                        <article
                                  class="partial tile media image-top  type-article"
                                  data-crop="marquee_large_2x"
                                  data-headline-style="heading-content"
                                >
                                    <!-- Image Media -->
                                    <a class="media-img margin-16-bottom" href="/weight-loss/keto-flu">
                                      <div
                                        class="component lazy-image  marquee_large_2x
                                          
                                          
                                          
                                          "
                                        data-src="https://cdn-img.health.com/sites/default/files/styles/large_16_9/public/1485969006/GettyImages-163844925_1_0_0.jpg?itok&#x3D;HrEozGmC"
                                        data-alt="Fatigue sick tired flu symptoms keto flu"
                                        data-title="What is keto flu?"
                                        
                                        
                                        >
                                        
                                        <noscript>
                                          <div class="inner-container">
                                            <img src="https://cdn-img.health.com/sites/default/files/styles/large_16_9/public/1485969006/GettyImages-163844925_1_0_0.jpg?itok&#x3D;HrEozGmC" alt="Fatigue sick tired flu symptoms keto flu">
                                          </div>
                                        </noscript>
                                        <div class="inner-container js-inner-container">
                                        </div>
                                        
                                      </div>
                                    </a>
                                
                                
                                  <!-- Body -->
                                  <div class="media-body article-info bucket-margin margin-24-bottom clearfix">
                                      <a class="unskinned display-inline-block eyebrow-link margin-4-bottom" href="/weight-loss">
                                        <div class="category heading-eyebrow">
                                          Weight Loss
                                        </div>
                                      </a>
                                
                                    <div class="headline heading-3 heading-content margin-8-bottom media-heading">
                                      <a href="/weight-loss/keto-flu">
                                           Keto Flu Explained: Why Low-Carb Diets Can Make You Feel Sick and Tired
                                      </a>
                                    </div>
                                
                                    <div class="article-info-extended">
                                
                                
                                      <!-- Summary/Dek -->
                                
                                    </div>
                                
                                
                                  </div>
                                </article>
                                        <article
                                  class="partial tile media image-top  type-article"
                                  data-crop="marquee_large_2x"
                                  data-headline-style="heading-content"
                                >
                                    <!-- Image Media -->
                                    <a class="media-img margin-16-bottom" href="/weight-loss/woman-lost-100-pounds-eating-pizza-on-keto-diet">
                                      <div
                                        class="component lazy-image  marquee_large_2x
                                          
                                          
                                          
                                          "
                                        data-src="https://cdn-img.health.com/sites/default/files/styles/large_16_9/public/1525365019/slack-imgs-2.jpg?itok&#x3D;xM_vKNGz"
                                        data-alt="Elena Juarez"
                                        data-title="Elena Juarez"
                                        
                                        
                                        >
                                        
                                        <noscript>
                                          <div class="inner-container">
                                            <img src="https://cdn-img.health.com/sites/default/files/styles/large_16_9/public/1525365019/slack-imgs-2.jpg?itok&#x3D;xM_vKNGz" alt="Elena Juarez">
                                          </div>
                                        </noscript>
                                        <div class="inner-container js-inner-container">
                                        </div>
                                        
                                      </div>
                                    </a>
                                
                                
                                  <!-- Body -->
                                  <div class="media-body article-info bucket-margin margin-24-bottom clearfix">
                                      <a class="unskinned display-inline-block eyebrow-link margin-4-bottom" href="/weight-loss">
                                        <div class="category heading-eyebrow">
                                          Weight Loss
                                        </div>
                                      </a>
                                
                                    <div class="headline heading-3 heading-content margin-8-bottom media-heading">
                                      <a href="/weight-loss/woman-lost-100-pounds-eating-pizza-on-keto-diet">
                                          This Woman Followed a Keto Diet and Lost 100 Pounds—Without Giving Up Pizza
                                      </a>
                                    </div>
                                
                                    <div class="article-info-extended">
                                
                                
                                      <!-- Summary/Dek -->
                                
                                    </div>
                                
                                
                                  </div>
                                </article>
                            </div>
          
                  
                  
                    <div
                        id="div-gpt-leaderboard-fixed-6"
                        data-tier="4"
                              
                      class="ad ad-container ad-wrapper  desktop-ad tablet-ad karma-ad"
                      data-dimensions="728x90" role="complementary" aria-hidden="true"></div>
                  
                  
                  
                  
                    <div
                        id="div-gpt-mob-square-flex-6"
                        data-tier="4"
                              
                      class="ad ad-container ad-wrapper  mobile-ad karma-ad"
                      data-dimensions="300x250" role="complementary" aria-hidden="true"></div>
                  
                  
                  
          </div>

      </div>

          <!-- Sidebar -->
          <div class="article-small-sidebar sidebar-right is-narrow"
            data-tracking-zone="right-rail"
          >
            <div class="sidebar-item">
          
              
              
                <div
                    id="div-gpt-square-flex-1"
                    data-tier="1"
                          
                  class="ad ad-container ad-wrapper  desktop-only karma-ad"
                  data-dimensions="300x600;300x250;160x600" role="complementary" aria-hidden="true"></div>
              
              
          
                
                <div 
                 class="component outbrain clearfix  " data-action="outbrain-component"  data-tracking-zone=outbrain-right-rail>
                  <div class="LAZYBRAIN "
                      data-src="https://www.health.com/celebrities/halle-berry-keto-diet-intermittent-fasting"
                      data-widget-id="SB_24"
                      data-ob-template="health"
                      
                      
                  >
                  </div>
                </div>
                
          
                
                
                  <div
                      id="div-gpt-square-fixed-1"
                      data-tier="2"
                            
                    class="ad ad-container ad-wrapper type-300-flex desktop-only karma-ad"
                    data-dimensions="300x250" role="complementary" aria-hidden="true"></div>
                
                
          
          
                    <div class="component feed clearfix"
                      data-endpoint="/element-api/content-proxy/documents"data-request-data="%7B%22count%22%3A4%2C%22crops%22%3A%22thumbnail%2Cmarquee_large_2x%2Capp_list_thumbnail_2x%2Cmedium_2x%22%2C%22page%22%3A1%2C%22types%22%3A%22article%2Cgallery%2Crecipe%22%2C%22excluded%22%3A528062%7D"data-partial="list-item"data-flair-size="30"data-type="feed"data-title="Read More"data-native_ad="%7B%22dimensions%22%3A%22481x100%22%2C%22placement%22%3A%22rail%22%2C%22priority%22%3A6%7D"data-nativekey="qo445sdtibZ3rp6JqnydtnH4">
                      <h3 class="subtitle">Read More</h3>
                    
                    </div>
                        <div class="component newsletter-callout " data-newsletter-type="newsletter-callout">
                    <div class="partial tout">
                      <div class="tout-content-wrapper">
                        <h3>HEALTH NEWSLETTERS</h3>
                        <div class="tout-content">Get easy recipes, 30-day fitness challenges, videos, and more.</div>
                      </div>
                          <div class="button-style">
                            <a href="https://pages.email.health.com/newsletters/?source&#x3D;HA_CMS_Art_RR"  target="_blank" > Sign up </a>
                          </div>
                    </div>
                  </div>
          
                <div class="karma-sticky-rail">
                  
                    <div
                      class="ad-sticky-container desktop-only height-250px karma-ad"
                    >
                  
                    <div
                        id="div-gpt-square-fixed-2"
                        data-tier="3"
                              
                      class="ad ad-container ad-wrapper type-300-flex desktop-only karma-ad"
                      data-dimensions="300x250" role="complementary" aria-hidden="true"></div>
                    </div>
                  
                  
                    <div class="ad-sticky-container desktop-only">
                    <div  id="ad_outbrain_0x0_RR_d" data-dimensions="0x0" data-tgxsticky="rail" data-tgxpriority="-1"
                     class="component outbrain clearfix ad desktop-only outbrain-rail-sticky " data-action="outbrain-component"  data-tracking-zone=outbrain-right-rail>
                      <div class="LAZYBRAIN "
                          data-src="https://www.health.com/celebrities/halle-berry-keto-diet-intermittent-fasting"
                          data-widget-id="SB_30"
                          data-ob-template="health"
                          
                          
                      >
                      </div>
                    </div>
                    </div>
                </div>
            </div>
          </div>

      <aside class="content article tags">
        
      </aside>
      
    </main>
  </div>
</div>

      
      
        <div
            id="div-gpt-related"
            data-tier="1"
                  
          class="ad ad-container ad-wrapper type-gum-gum desktop-ad tablet-ad karma-ad"
          data-dimensions="1x6" role="complementary" aria-hidden="true"></div>
      
      
    <div class="above-footer">
        <div class="component subscribe-callout media">
          <div class="media-img">
            <div
              class="component lazy-image evergreen-cover 
                
                
                 skip-imagesvc 
                "
              data-src="//subscription-assets.timeinc.com/current/4478_top2_205_thumb.jpg"
              data-alt=""
              data-title=""
              
              
              >
              
              <noscript>
                <div class="inner-container">
                  <img src="//subscription-assets.timeinc.com/current/4478_top2_205_thumb.jpg" alt="">
                </div>
              </noscript>
              <div class="inner-container js-inner-container">
              </div>
              
            </div>
            <div
              class="component lazy-image latest-cover 
                
                
                 skip-imagesvc 
                "
              data-src="//subscription-assets.timeinc.com/current/4478_top1_205_thumb.jpg"
              data-alt=""
              data-title=""
              
              
              >
              
              <noscript>
                <div class="inner-container">
                  <img src="//subscription-assets.timeinc.com/current/4478_top1_205_thumb.jpg" alt="">
                </div>
              </noscript>
              <div class="inner-container js-inner-container">
              </div>
              
            </div>
          </div>
          <div class="media-body">
            <div class="partial tout">
              <div class="tout-content-wrapper">
                <h3>Subscribe &amp; Save</h3>
                <div class="tout-content">Subscribe today and save 82% off the cover price.</div>
              </div>
                  <div class="button-style">
                    <a href="https://www.magazine.store/health/?utm_source&#x3D;health&amp;utm_medium&#x3D;internal&amp;utm_campaign&#x3D;i805hlrfw857"  target="_blank" > Subscribe Now </a>
                  </div>
            </div>
          </div>
        </div>
      <div class="component newsletter-callout " >
          <div
            class="component lazy-image  
              
              
              
              "
            data-src="/img/newsletter/running-banner-301.jpg"
            data-alt=""
            data-title=""
            
            
            >
            
            <noscript>
              <div class="inner-container">
                <img src="/img/newsletter/running-banner-301.jpg" alt="">
              </div>
            </noscript>
            <div class="inner-container js-inner-container">
            </div>
            
          </div>
        <div class="partial tout">
          <div class="tout-content-wrapper">
            <h3>HEALTH NEWSLETTERS</h3>
            <div class="tout-content">Get easy recipes, 30-day fitness challenges, videos, and more.</div>
          </div>
              <div class="button-style">
                <a href="https://pages.email.health.com/newsletters/?source&#x3D;HA_CMS_Art_Footer"  target="_blank" > Sign up </a>
              </div>
        </div>
      </div>
    </div>
    <footer class="main padding-24-top ">
      <div class="logo-container margin-0-auto">
        <a class="display-inline-block" href="/" aria-label="Logo"><?xml version="1.0" encoding="utf-8"?>
      <!-- Generator: Adobe Illustrator 15.1.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->
      <!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">
      <svg xmlns="http://www.w3.org/2000/svg" width="90" height="50" viewBox="0 0 540 150">
        <g>
          <polygon points="329.1 146.9 329.1 .2 355.7 .2 355.7 146.9"/>
          <path d="M436.9,145 C431.7,146.7 422.4,148.3 415.5,148.3 C392.4,148.3 382.7,137.8 382.7,116.5 L382.7,58.5 L364.6,58.5 L364.6,36.6 L382.7,36.6 L382.7,0.1 L409.3,0.1 L409.3,36.6 L436.1,36.6 L436.1,58.5 L409.3,58.5 L409.3,111.1 C409.3,120.3 412.5,124.7 421,124.7 C426.2,124.7 432.7,123.4 436.9,121.7 L436.9,145 Z"/>
          <polygon points="29.9 58.8 84 58.8 84 .2 113 .2 113 146.9 84 146.9 84 85.8 29.9 85.8 29.9 146.9 .9 146.9 .9 .2 29.9 .2"/>
          <path d="M219.5 88.4C219.5 59.7 206.9 34 172.4 34 139.9 34 122.7 59 122.7 91.8 122.7 126.8 141.8 149.6 176.4 149.6 190.4 149.6 206.3 147.1 215.7 142.2L215.7 118.3C206.5 123.2 193.1 126.8 180.8 126.8 163.3 126.8 152.4 118.6 150.2 99.8L219.1 99.8C219.5 96 219.5 92.1 219.5 88.4zM150 81C151.9 62.8 160 55.5 172.8 55.5 185 55.5 193.1 65.9 193.1 81L150 81zM272.2 34C257.5 34 245.3 36.4 235.7 40.7L235.7 64.6C245.3 59.8 257.3 57.1 268.8 57.1 286.3 57.1 290.1 66.1 290.2 80.8 283.9 79 276.1 77.9 268.5 77.9 244.1 77.9 226.1 91 226.1 114.5 226.1 135.9 240 149.4 261.8 149.4 274.4 149.4 284 145.3 291.2 136.8L291.2 146.8 317 146.8 317 76.1C317 50.7 303.3 34 272.2 34zM268.2 129.3C258.1 129.3 251.9 124.1 251.9 113.6 251.9 103.6 257.8 96.4 273 96.4 279 96.4 285.1 97.4 290.2 98.8L290.2 104.4C290.2 120 280.2 129.3 268.2 129.3zM503.9 34C491.6 34 480.9 39.2 474.4 46.8L474.4.1 447.7.1 447.7 146.8 474.4 146.8 474.4 86C474.4 68.1 481.3 57.5 495.6 57.5 507.1 57.5 513 65.3 513 80.5L513 146.8 539.7 146.8 539.7 75.3C539.6 52.3 530.7 34 503.9 34z"/>
        </g>
      </svg>
      </a>
      </div>
      <div class="social-container margin-0-auto padding-24-tb display-flex rule-bottom">
          <span
            class="icon icon-facebook-circle-stroke social-stroke-icon color-accent margin-4-right"
             
          >
              <a href="https://www.facebook.com/health" class="display-block " target="_blank" title=" share" aria-label=" share">
            <svg width="36" height="36" xmlns="http://www.w3.org/2000/svg"><g fill-rule="evenodd" fill="none" stroke="null"><path d="M32.95 18c0 8.258-6.693 14.95-14.95 14.95S3.05 26.26 3.05 18 9.742 3.05 18 3.05 32.95 9.74 32.95 18" stroke-width="2" stroke="#B7B4B4"/><path d="M19.718 13.698c.433-.014.866-.004 1.3-.004h.18V11.57c-.232-.023-.473-.054-.716-.065-.445-.02-.89-.04-1.336-.03-.68.013-1.323.17-1.884.55-.644.435-.998 1.05-1.132 1.773-.057.3-.07.607-.08.912-.01.477-.002.953 0 1.43v.18h-2.16v2.373h2.147v5.966h2.622V18.7h2.134l.33-2.385h-.482c-.608.002-2.004 0-2.004 0s.006-1.177.02-1.687c.02-.7.46-.912 1.057-.932" fill="#B7B4B4"/></g></svg>    </a>
          </span>
          <span
            class="icon icon-twitter-circle-stroke social-stroke-icon color-accent margin-4-right"
             
          >
              <a href="https://twitter.com/goodhealth" class="display-block " target="_blank" title=" share" aria-label=" share">
            <svg width="36" height="36" xmlns="http://www.w3.org/2000/svg"><g fill-rule="evenodd" fill="none" stroke="null"><path d="M32.977 18c0 8.272-6.705 14.976-14.977 14.976S3.023 26.272 3.023 18C3.023 9.728 9.728 3.024 18 3.024S32.977 9.728 32.977 18" stroke-width="2" stroke="#B7B4B4"/><path d="M15.783 21.476c-1.48-.052-2.404-1.114-2.65-1.976.413.078.82.063 1.222-.037.01-.002.02-.01.04-.018-.8-.187-1.42-.616-1.848-1.307-.286-.46-.422-.962-.418-1.514.4.214.81.333 1.26.345-.607-.44-1.01-1.01-1.177-1.73-.164-.73-.057-1.42.306-2.07 1.54 1.813 3.492 2.81 5.872 2.973-.02-.113-.037-.21-.048-.31-.08-.67.054-1.295.416-1.86.454-.71 1.1-1.15 1.93-1.29.96-.156 1.796.117 2.495.795.046.045.085.06.15.045.586-.125 1.14-.335 1.657-.635l.04-.02h.02c-.225.664-.635 1.174-1.22 1.55.553-.06 1.08-.206 1.586-.426l.01.013c-.11.143-.215.29-.327.427-.302.373-.65.7-1.035.984-.034.025-.05.05-.05.09.016.424 0 .846-.053 1.266-.11.885-.352 1.73-.73 2.534-.39.833-.9 1.585-1.54 2.246-1.083 1.12-2.39 1.844-3.912 2.18-.52.115-1.05.173-1.585.19-1.64.046-3.16-.36-4.554-1.224l-.066-.043c.996.107 1.94-.02 2.85-.393.484-.197.93-.457 1.354-.79" fill="#B7B4B4"/></g></svg>    </a>
          </span>
          <span
            class="icon icon-pinterest-circle-stroke social-stroke-icon color-accent margin-4-right"
             
          >
              <a href="https://www.pinterest.com/health/" class="display-block " target="_blank" title=" share" aria-label=" share">
            <svg width="36" height="36" xmlns="http://www.w3.org/2000/svg"><g fill-rule="evenodd" fill="none" stroke="null"><path d="M32.976 18c0 8.272-6.705 14.976-14.976 14.976-8.27 0-14.976-6.704-14.976-14.976C3.024 9.728 9.73 3.024 18 3.024S32.976 9.728 32.976 18" stroke-width="2" stroke="#B7B4B4"/><path d="M17.162 20.54c-.012.038-.022.072-.03.105-.505 1.976-.562 2.415-1.08 3.332-.247.437-.525.85-.834 1.246-.034.044-.067.102-.137.088-.07-.01-.08-.08-.08-.14-.08-.6-.13-1.2-.11-1.81.03-.79.13-1.06 1.15-5.34.02-.06 0-.12-.02-.18-.24-.65-.29-1.32-.08-2 .46-1.46 2.12-1.57 2.41-.36.18.75-.292 1.72-.654 3.16-.3 1.19 1.1 2.04 2.298 1.17 1.106-.8 1.534-2.72 1.45-4.08-.16-2.71-3.13-3.29-5.02-2.42-2.16 1-2.65 3.68-1.675 4.91.126.157.22.25.18.41-.06.244-.117.49-.186.735-.05.184-.2.25-.384.175-.36-.148-.66-.377-.9-.678-.83-1.026-1.07-3.057.03-4.776 1.212-1.906 3.47-2.676 5.534-2.443 2.468.28 4.02 1.964 4.316 3.873.13.87.035 3.012-1.186 4.53-1.404 1.74-3.68 1.854-4.73.785-.08-.08-.146-.18-.225-.272" fill="#B7B4B4"/></g></svg>    </a>
          </span>
          <span
            class="icon icon-instagram-circle-stroke social-stroke-icon color-accent margin-4-right"
             
          >
              <a href="https://www.instagram.com/healthmagazine" class="display-block " target="_blank" title=" share" aria-label=" share">
            <svg width="36" height="36" xmlns="http://www.w3.org/2000/svg"><g fill-rule="evenodd" fill="none" stroke="null"><path d="M32.95 18c0 8.257-6.693 14.95-14.95 14.95S3.05 26.258 3.05 18 9.742 3.05 18 3.05 32.95 9.742 32.95 18" stroke-width="2" stroke="#B7B4B4"/><path d="M22.624 22c0 .344-.28.624-.623.624h-8.47c-.342 0-.62-.28-.62-.623v-5.13h1.218c-.07.29-.104.59-.104.9 0 2.07 1.677 3.75 3.75 3.75 2.07 0 3.75-1.68 3.75-3.75 0-.306-.038-.604-.108-.89h1.22V22zm-7.137-5.13c.356-.907 1.24-1.552 2.274-1.552 1.04 0 1.92.645 2.28 1.553.11.28.17.58.17.9 0 1.347-1.1 2.444-2.44 2.444-1.345 0-2.442-1.097-2.442-2.443 0-.314.06-.615.17-.89zm4.916-3.576c0-.19.154-.344.344-.344h1.49c.19 0 .344.154.344.344v1.49c0 .19-.15.344-.34.344h-1.49c-.19 0-.34-.154-.34-.344v-1.49zM22 11.592h-8.478c-1.065 0-1.93.865-1.93 1.93v8.48c0 1.064.865 1.93 1.93 1.93h8.48c1.065 0 1.93-.866 1.93-1.93v-8.48c0-1.065-.865-1.93-1.93-1.93z" fill="#B7B4B4"/></g></svg>    </a>
          </span>
      </div>
      <nav class="footer-links margin-0-auto padding-16-tb rule-bottom" data-tracking-zone="footer">
        <section>
          <a href="/service/about">ABOUT US</a>
          <ul class="margin-8-top">
            <li><a href="https://www.timeinc.com/careers/" >TIME INC CAREERS</a></li>
            <li><a href="https://www.health.com/microsites/buzz/index.html" >HEALTH SPOTLIGHT</a></li>
            <li><a href="https://www.health.com/health/wp/0%2C%2C20802680%2C00.html" >SOCIAL MEDIA TERMS</a></li>
            <li><a href="https://www.health.com/microsites/magazine/fullmediakit.pdf" >ADVERTISE WITH HEALTH</a></li>
            <li><a href="https://subscription-assets.health.com/prod/assets/themes/magazines/SUBS/templates/velocity/site/ha-dp2011/lp.html?xid&#x3D;decisionpagemagpage" >TABLET EDITION</a></li>
          </ul>
        </section>
        <section>
          <a href="https://www.magazine.store/health/">SUBSCRIBE</a>
          <ul class="margin-8-top">
            <li><a href="https://www.magazine.store/health/" >GIVE A GIFT</a></li>
            <li><a href="https://secure.customersvc.com/servlet/Show?WESPAGE&#x3D;ha/home.html&amp;MSRSMAG&#x3D;HA" >RENEW YOUR SUBSCRIPTION</a></li>
            <li><a href="/health/service/magazine" >HEALTH MAGAZINE</a></li>
            <li><a href="https://pages.email.health.com/newsletters/?source&#x3D;HA_CMS_FooterLink" >NEWSLETTERS</a></li>
          </ul>
        </section>
        <section>
          <a href="/service/contact-us">CONTACT US</a>
          <ul class="margin-8-top">
            <li><a href="/service/help" >HELP</a></li>
            <li><a href="https://www.health.com/health/wp/0%2C%2C20483796%2C00.html" >SWEEPSTAKES</a></li>
            <li><a href="https://w1.buysub.com/servlet/CSGateway?cds_mag_code&#x3D;HTH" >CUSTOMER SERVICE</a></li>
            <li><a href="/sitemap" >SITE MAP</a></li>
          </ul>
        </section>
      </nav>
      <div class="footer-legal padding-16-tb text-align-center">
        All products and services featured are selected by our editors. Health.com may receive compensation for some links to products and services on this website. Offers may be subject to change without notice. &copy; 2017 Health Media Ventures, Inc. Health.com is part of the Meredith Health Group. All rights reserved. The material in this site is intended to be of general informational use and is not intended to constitute medical advice, probable diagnosis, or recommended treatments. See the <a rel="nofollow" href="https://www.timeinc.net/subs/privacy/termsofservice/healthtos.html">Terms of Service</a> and <a rel="nofollow" href="https://subscription.timeinc.com/storefront/privacy/health/generic_privacy_new.html?dnp-source=E">Privacy Policy</a> (<a rel="nofollow" href="https://subscription.timeinc.com/storefront/privacy/health/generic_privacy_new.html?dnp-source=E#california">Your California Rights</a>)for more information. <a rel="nofollow" class="adchoice" href="https://subscription-assets.timeinc.com/prod/assets/themes/magazines/default/template-resources/html/legal/ti-corp-behavioral.html" target="_blank">Ad Choices</a> | <a href="https://app-de.onetrust.com/app/#/webform/0c410d51-8e85-4308-9bb9-37c24a461ccb" class="util eu-data-subject-requests">EU Data Subject Requests</a>
      </div>
    </footer>
    
    <div id="page-segment-values">
      <div class="keyvals"
          data-content_author_name="Samantha Lauriello"
          data-content_cms_desk=""
          data-content_cms_category="Celebrities"
          data-content_cms_sub_category=""
          data-content_cms_id="528062"
          data-content_cms_tags=""
          data-content_cms_terms="Celebrities"
          data-content_featured_image="https://cdn-img.health.com/sites/default/files/styles/large_16_9/public/styles/main/public/halle-berry-diet-gettyimages-961643426.jpg?itok&#x3D;HcN1mF65&amp;1533585750"
          data-content_headline="Halle Berry Says She Does Intermittent Fasting on the Keto Diet—Is That Healthy?"
          data-content_modified_date=""
          data-content_published_date="2018-08-06T20:07:34.000Z"
          data-content_shown_on_platform="own"
          data-content_type="article"
          data-path="/celebrities/halle-berry-keto-diet-intermittent-fasting"
          data-referrer=""
          data-search=""
          data-content_is_post="post"
          data-time_inc_application="front end"
          data-time_inc_brand="health.com"
          data-title="Halle Berry Says She Does Intermittent Fasting on the Keto Diet—Is That Healthy?"
          data-content_syndicated="internal"
          data-content_syndicated_brand="health.com"
          data-content_syndicated_url="https://www.health.com/celebrities/halle-berry-keto-diet-intermittent-fasting"
          data-content_nlp_sentiment_label="neutral"
          data-content_nlp_sentiment_score=""
          data-content_nlp_sentiment_magnitude="11.9"
          data-content_nlp_entities="strategy|Berry|Halle Berry|Fasting|actress"
          data-content_nlp_payload="{&quot;entities&quot;:[{&quot;type&quot;:&quot;OTHER&quot;,&quot;text&quot;:&quot;strategy&quot;,&quot;relevance&quot;:0.23466115,&quot;disambiguation&quot;:{}},{&quot;type&quot;:&quot;PERSON&quot;,&quot;text&quot;:&quot;Berry&quot;,&quot;relevance&quot;:0.1332069,&quot;disambiguation&quot;:{}},{&quot;type&quot;:&quot;PERSON&quot;,&quot;text&quot;:&quot;Halle Berry&quot;,&quot;relevance&quot;:0.12019792,&quot;disambiguation&quot;:{&quot;wikipedia_url&quot;:&quot;https://en.wikipedia.org/wiki/Halle_Berry&quot;,&quot;mid&quot;:&quot;/m/03knl&quot;}},{&quot;type&quot;:&quot;OTHER&quot;,&quot;text&quot;:&quot;Fasting&quot;,&quot;relevance&quot;:0.108873,&quot;disambiguation&quot;:{}},{&quot;type&quot;:&quot;PERSON&quot;,&quot;text&quot;:&quot;actress&quot;,&quot;relevance&quot;:0.10253759,&quot;disambiguation&quot;:{}},{&quot;type&quot;:&quot;OTHER&quot;,&quot;text&quot;:&quot;Keto Diet&quot;,&quot;relevance&quot;:0.02057726,&quot;disambiguation&quot;:{&quot;mid&quot;:&quot;/m/03cg86&quot;,&quot;wikipedia_url&quot;:&quot;https://en.wikipedia.org/wiki/Ketogenic_diet&quot;}},{&quot;type&quot;:&quot;OTHER&quot;,&quot;text&quot;:&quot;Intermittent Fasting&quot;,&quot;relevance&quot;:0.0150120575,&quot;disambiguation&quot;:{}},{&quot;type&quot;:&quot;PERSON&quot;,&quot;text&quot;:&quot;Cynthia Sass&quot;,&quot;relevance&quot;:0.013740186,&quot;disambiguation&quot;:{&quot;mid&quot;:&quot;/m/09tvw7l&quot;}},{&quot;type&quot;:&quot;OTHER&quot;,&quot;text&quot;:&quot;diet&quot;,&quot;relevance&quot;:0.0126632415,&quot;disambiguation&quot;:{}},{&quot;type&quot;:&quot;OTHER&quot;,&quot;text&quot;:&quot;weight&quot;,&quot;relevance&quot;:0.010392876,&quot;disambiguation&quot;:{}}],&quot;categories&quot;:[{&quot;label&quot;:&quot;/Health/Nutrition/Special &amp; Restricted Diets&quot;,&quot;score&quot;:0.95},{&quot;label&quot;:&quot;/Beauty &amp; Fitness/Weight Loss&quot;,&quot;score&quot;:0.76}],&quot;docSentiment&quot;:{&quot;magnitude&quot;:11.9,&quot;score&quot;:0,&quot;label&quot;:&quot;neutral&quot;},&quot;language&quot;:&quot;en&quot;}"
          data-content_nlp_categories="/Health/Nutrition/Special &amp; Restricted Diets|/Beauty &amp; Fitness/Weight Loss"
      ></div>
    </div>
      <div id="site-components"
        data-brand-sync=""
        data-brand-async=""
        data-core-sync="navigation,lazy-image,overlay,popup,auth,line-clamp,gdpr"
        data-core-async="video,feed,gallery,gallery-test,gallery-view-all,gallery-everything-in,dropdown,autofill-content-container,expander,outbrain,newsletter-signup-modal,vertical-gallery,search-results-form,embed-playbuzz,embed-rakuten,embed-thinglink,aside,pinterest-board,pinterest-pin,topic-sub-nav,embed-facebook,embed-instagram,embed-twitter,build-a-meal,ecommerce-hub,content-loader,before-after,burst-text,bucket,progress-bar,amazon-price,embed-brandpulse,embed-apester,glossary-header,embed-omnivirt,map-overlay,tabs,recirculation,share-new,circular-countdown"
      ></div>

  </body>
</html>
